View Issue Details

IDProjectCategoryView StatusLast Update
0036107LazarusIDEpublic2019-10-01 13:54
ReporterserbodAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.0.4Product Build 
Target VersionFixed in Version2.2 
Summary0036107: Install/Uninstall Packages window show only last lines of package info
DescriptionPackage -> Install/Uninstall Packages -> Package info frame in bottom part of window
Always show scrolled to past line, hiding description.

Please, make it show from first line by default.
And move "Author:" part after description.
And remove "Description / Abstract:" prefix
Additional InformationFCL package, how I see it now:
================
pascal.
License: modified LGPL-2
Filename: C:\fpcupdeluxe\lazarus\packager\registration\fcl.lpk
Current state: installed, Base, cannot be uninstalled, RunAndDesignTime

================

Proposed view:
================
The FCL - FreePascal Component Library provides the base classes for object pascal.

Author: Lazarus
License: modified LGPL-2
Filename: C:\fpcupdeluxe\lazarus\packager\registration\fcl.lpk
================
TagsNo tags attached.
Fixed in Revision61942
LazTarget2.2
Widgetset
Attached Files

Activities

Martin Friebe

2019-09-28 22:14

manager   ~0118178

Made the following changes:

rev 61942: Fixed scrolling
rev 61943: Added a 2nd memo for License, so this is always visible

I kept the Author on top, as it is only fair to display this.
It is usually only one line, so enough of the description can be seen. (And the memo sizes can be changed by splitters)

I kept the Labels, as they mirror the source of the info in the package's option dialog.

---
Please test, and close if ok.

serbod

2019-10-01 13:45

reporter   ~0118230

Yes, that much better. Separate memo for Licence is very good solution.

What point in displaying author first and "Description / Abstract" text? On some packages info now looks like that:
===============
Author: Olivier GUILBAUD <golivier@free.fr>, Gerard Visent <gerardusmercator@gmail.com>, Mattias Gaertner, Alexander du Plessis, Silvio Clecio
Description / Abstract: A todo list window for the Lazarus IDE
===============

It take some time to visually read and "parse" all those text before actual description. For comparsion, same info in proposed formatting:
===============
A todo list window for the Lazarus IDE

Author: Olivier GUILBAUD <golivier@free.fr>, Gerard Visent <gerardusmercator@gmail.com>, Mattias Gaertner, Alexander du ===============

serbod

2019-10-01 13:54

reporter   ~0118232

Small notice:
Some descriptions have extra line breaks on end, and they need Trim() before adding to memo.
Description := Trim(Info.Description);

InstallPkgSetDlg.pas - TInstallPkgSetDialog.UpdatePackageInfo() code sample:
================
    if PackageLink = nil then
    begin
      Author := Info.Author;
      Description := Trim(Info.Description);
      License := Info.License;
    end
    else
    begin
      Author := PackageLink.Author;
      Description := Trim(PackageLink.Description);
      License := PackageLink.License;
    end;

    if Description<>'' then
      PkgInfoMemo.Lines.Add(Description);
    PkgInfoMemo.Lines.Add('');
    if Author<>'' then
      PkgInfoMemo.Lines.Add(lisPckOptsAuthor + ': ' + Author);
    if License<>'' then
      PkgInfoMemoLicense.Lines.Add(lisPckOptsLicense + ': ' + License);

    PkgInfoMemo.Lines.Add(Format(lisOIPFilename, [Info.LPKFilename]));
==============

Issue History

Date Modified Username Field Change
2019-09-27 13:05 serbod New Issue
2019-09-28 21:20 Martin Friebe Assigned To => Martin Friebe
2019-09-28 21:20 Martin Friebe Status new => assigned
2019-09-28 22:14 Martin Friebe Status assigned => resolved
2019-09-28 22:14 Martin Friebe Resolution open => fixed
2019-09-28 22:14 Martin Friebe Fixed in Version => 2.2
2019-09-28 22:14 Martin Friebe Fixed in Revision => 61942
2019-09-28 22:14 Martin Friebe LazTarget => 2.2
2019-09-28 22:14 Martin Friebe Note Added: 0118178
2019-10-01 13:45 serbod Note Added: 0118230
2019-10-01 13:54 serbod Note Added: 0118232