View Issue Details

IDProjectCategoryView StatusLast Update
0036109LazarusWidgetsetpublic2019-10-15 23:13
ReporterBlake Assigned ToDmitry Boyarintsev  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformDarwinOSmacOS Mojave 
Product Version2.1 (SVN) 
Summary0036109: (Cocoa) TSpeedButton does not respond to clicks properly if parent is TGroupBox
DescriptionWhen a TSpeedButton is in a TGroupBox, mouse click events appear to respond to a different rectangle area (shifted a few pixels above the button).
Mouse enter/leave events are responding to the correct frame.
I tried a TSpeedButton in a TPanel instead, and it works ok.

This bug isn't a big deal with large buttons, but for little ones (about 10 pixels high) it becomes confusing for the user.
Steps To Reproduce- run attached project
- click near the bottom of the button in the groupbox (a few pixels)
- ...it does not respond to the click
- click above the button (a few pixels, seems to be the same offset)
- ...it responds even though the mouse is not over the button

- notice that the OnMouseEnter and OnMouseLeave callbacks are working correctly, and clicks on the button in TPanel are working correctly
Additional InformationAlso reproduced same behaviour in trunk revision 61756.
TagsNo tags attached.
Fixed in Revision62061
LazTarget-
WidgetsetCocoa
Attached Files

Activities

Blake

2019-09-27 21:02

reporter  

Dmitry Boyarintsev

2019-10-15 05:27

developer   ~0118610

please test and close if ok

Blake

2019-10-15 23:13

reporter   ~0118624

Tested with lazarus revision 62064, and it is working great. Thanks!

Issue History

Date Modified Username Field Change
2019-09-27 21:02 Blake New Issue
2019-09-27 21:02 Blake File Added: testSpeedButtonInGroupBox.zip
2019-10-15 05:27 Dmitry Boyarintsev Assigned To => Dmitry Boyarintsev
2019-10-15 05:27 Dmitry Boyarintsev Status new => resolved
2019-10-15 05:27 Dmitry Boyarintsev Resolution open => fixed
2019-10-15 05:27 Dmitry Boyarintsev Fixed in Revision => 62061
2019-10-15 05:27 Dmitry Boyarintsev LazTarget => -
2019-10-15 05:27 Dmitry Boyarintsev Widgetset Cocoa => Cocoa
2019-10-15 05:27 Dmitry Boyarintsev Note Added: 0118610
2019-10-15 23:13 Blake Status resolved => closed
2019-10-15 23:13 Blake Note Added: 0118624