View Issue Details

IDProjectCategoryView StatusLast Update
0036111LazarusWidgetsetpublic2020-07-15 15:46
ReporterFrederick Assigned ToDmitry Boyarintsev  
PrioritynormalSeverityminorReproducibilityalways
Status assignedResolutionreopened 
PlatformMacOSmacOS 
Product Version2.0 
Summary0036111: StringGrid/DrawGrid selects and deletes text entry
DescriptionWhen entering data into a TStringGrid or TDrawGrid cell, the first keystroke enters the character, but also selects it. The second keystroke therefore deletes the first character.
Steps To ReproducePut a TStringGrid on a form, run, and try to enter 2 characters of text in a cell. The first character is selected, and the second character deletes it.
TagsNo tags attached.
Fixed in Revision62161
LazTarget-
WidgetsetCocoa
Attached Files

Activities

Frederick

2019-09-28 16:11

reporter  

StringGrid.zip (6,517 bytes)

Dmitry Boyarintsev

2019-11-03 01:27

developer   ~0118998

please test and close if ok

Dmitry Boyarintsev

2019-11-03 22:13

developer   ~0119023

r62180 reverts the fix

Trevor Roydhouse

2020-07-15 11:50

reporter   ~0124035

I downloaded the demo from https://forum.lazarus.freepascal.org/index.php/topic,46787.msg334041.html#msg334041.

I'm using Lazarus v2.1.0 r63549, FPC v3.3.1 r45778, macOS 10.14.6 (with sup update), Xcode 11.3.1.

The problem is worse than originally described.

Whichever cell I choose to edit which already contains content, the first character is focussed, entering a character deletes it. In addition, I cannot edit any other cell. If I double click on another cell, the red cell outline is appears, but anything I enter turns up in the first cell I edited! It seems that the focus remains stuck on the first cell I edited. See attached pic.

bortok

2020-07-15 15:46

reporter   ~0124042

The problem started after 63541. https://bugs.freepascal.org/view.php?id=37202

Issue History

Date Modified Username Field Change
2019-09-28 16:11 Frederick New Issue
2019-09-28 16:11 Frederick File Added: StringGrid.zip
2019-11-03 01:27 Dmitry Boyarintsev Assigned To => Dmitry Boyarintsev
2019-11-03 01:27 Dmitry Boyarintsev Status new => resolved
2019-11-03 01:27 Dmitry Boyarintsev Resolution open => fixed
2019-11-03 01:27 Dmitry Boyarintsev Fixed in Revision => 62161
2019-11-03 01:27 Dmitry Boyarintsev LazTarget => -
2019-11-03 01:27 Dmitry Boyarintsev Widgetset Cocoa => Cocoa
2019-11-03 01:27 Dmitry Boyarintsev Note Added: 0118998
2019-11-03 22:13 Dmitry Boyarintsev Status resolved => assigned
2019-11-03 22:13 Dmitry Boyarintsev Resolution fixed => reopened
2019-11-03 22:13 Dmitry Boyarintsev Note Added: 0119023
2020-07-15 11:50 Trevor Roydhouse Note Added: 0124035
2020-07-15 11:50 Trevor Roydhouse File Added: Screen Shot 2020-07-15 at 7.46.46 pm.png
2020-07-15 15:46 bortok Note Added: 0124042