View Issue Details

IDProjectCategoryView StatusLast Update
0036113FPCPackagespublic2019-09-29 13:02
ReporterZamrony P. JuharaAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.0.4Product Build 
Target VersionFixed in Version3.3.1 
Summary0036113: HMACSHA1Match() cause infinite recursion
DescriptionHMACSHA1Match() function is calling itself and causing infinite recursion.

See line 182

https://github.com/graemeg/freepascal/blob/master/packages/hash/src/hmac.pp
TagsNo tags attached.
Fixed in Revision43087
FPCOldBugId
FPCTarget3.2.0
Attached Files

Activities

Michael Van Canneyt

2019-09-29 08:20

administrator   ~0118181

Seems to be a copy & paste error, fixed. Please test and close if OK.
Thanks for reporting !

Issue History

Date Modified Username Field Change
2019-09-29 07:18 Zamrony P. Juhara New Issue
2019-09-29 08:20 Michael Van Canneyt Assigned To => Michael Van Canneyt
2019-09-29 08:20 Michael Van Canneyt Status new => resolved
2019-09-29 08:20 Michael Van Canneyt Resolution open => fixed
2019-09-29 08:20 Michael Van Canneyt Fixed in Version => 3.3.1
2019-09-29 08:20 Michael Van Canneyt Fixed in Revision => 43087
2019-09-29 08:20 Michael Van Canneyt FPCTarget => 3.2.0
2019-09-29 08:20 Michael Van Canneyt Note Added: 0118181
2019-09-29 13:02 Zamrony P. Juhara Status resolved => closed