View Issue Details

IDProjectCategoryView StatusLast Update
0036121FPCCompilerpublic2019-10-03 19:41
ReporterMarģersAssigned ToSven Barth 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Platformx86_64OSlinuxOS Version.
Product Version3.3.1Product Build 
Target VersionFixed in Version3.3.1 
Summary0036121: missing define FPC_ISO
Descriptionin mode iso fpc do not provide define FPC_ISO,
in mode extendedpascal fpc do not provide define FPC_EXTENDEDPASCAL,
in mode fpc fpc do not provide define FPC_FPC (this might be intentional because it's default mode and "FPC_FPC looks awkward).
TagsNo tags attached.
Fixed in Revision43114
FPCOldBugId
FPCTarget-
Attached Files

Activities

Sven Barth

2019-10-03 14:35

manager   ~0118274

I've added both FPC_ISO and FPC_EXTENDEDPASCAL.

Please test and close if okay.

Issue History

Date Modified Username Field Change
2019-09-30 17:45 Marģers New Issue
2019-10-03 14:35 Sven Barth Assigned To => Sven Barth
2019-10-03 14:35 Sven Barth Status new => resolved
2019-10-03 14:35 Sven Barth Resolution open => fixed
2019-10-03 14:35 Sven Barth Fixed in Version => 3.3.1
2019-10-03 14:35 Sven Barth Fixed in Revision => 43114
2019-10-03 14:35 Sven Barth FPCTarget => -
2019-10-03 14:35 Sven Barth Note Added: 0118274
2019-10-03 19:41 Marģers Status resolved => closed