View Issue Details

IDProjectCategoryView StatusLast Update
0036152FPCLCLpublic2019-10-13 11:14
ReporterKarl-Michael SchindlerAssigned ToFlorian 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
PlatformdarwinOSMac OS XOS Version10.5, 10.6
Product VersionProduct Buildsvn version 61993 
Target VersionFixed in Version 
Summary0036152: svn version 61993 breaks building carbon-based lazarus.
Descriptionsvn version 61993 breaks building carbon-based lazarus with:

...
Compiling imglist.pp
controls.pp(473,1) Fatal: Internal error 200611031
Fatal: Compilation aborted
Steps To Reproducesvn up -r 61993
make bigide LCL_PLATFORM=carbon PP=ppc386 CPU_TARGET=i386 CPU_SOURCE=i386
Additional InformationI do not think it matters, but for the sake of completeness. System macOS 10.14.6, fpc 3.0.4 as installed though fink.

This command works with ppcx64:
make bigide LCL_PLATFORM=cocoa

but all i386 and arm platforms seem to be affected
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Relationships

duplicate of 0032352 new Compiling DoubleCommander project sometimes gives "Fatal: Internal error 200611031" message. 

Activities

Juha Manninen

2019-10-08 21:12

reporter   ~0118429

FPC Internal error is a compiler bug.
Try building Lazarus clean. Usually it helps.
If you find code that creates an Internal error systematically then report to FPC project.
This is not an LCL bug. The code compiles just fine.

Karl-Michael Schindler

2019-10-09 00:08

reporter   ~0118432

This is probably a duplicate of 32352.

Bart Broersma

2019-10-09 00:25

reporter   ~0118433

Please resolve as duplicate of 0032352.
I tried to do so when the report was still in "Lazarus", but lacked the rights (since it updates an issue in "fpc").

Issue History

Date Modified Username Field Change
2019-10-08 20:05 Karl-Michael Schindler New Issue
2019-10-08 21:12 Juha Manninen Note Added: 0118429
2019-10-09 00:08 Karl-Michael Schindler Note Added: 0118432
2019-10-09 00:23 Bart Broersma Project Lazarus => FPC
2019-10-09 00:25 Bart Broersma Note Added: 0118433
2019-10-13 11:14 Florian Assigned To => Florian
2019-10-13 11:14 Florian Status new => resolved
2019-10-13 11:14 Florian Resolution open => duplicate
2019-10-13 11:14 Florian FPCTarget => -
2019-10-13 11:14 Florian Relationship added duplicate of 0032352