View Issue Details

IDProjectCategoryView StatusLast Update
0036154FPCCompilerpublic2019-10-19 18:18
ReporterHans LuijtenAssigned ToFlorian 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformCocoaOSmacOSOS Version10.14.x
Product VersionProduct Build62009 
Target VersionFixed in Version 
Summary0036154: IDE SVN 62009 fails to compile under Cocoa (Internal error 2013121801)
DescriptionAfter updating from SVN to 62009, building the IDE fails with this error:

controls.pp(4649) Fatal: Internal error 2013121801
Fatal: Compilation aborted
make[1]: *** [alllclunits.ppu] Error 1
make: *** [lazbuild] Error 2

The previous version (62008) compiles just correctly.
Steps To Reproducesvn up
make LCL_PLATFORM=cocoa CPU_TARGET=x86_64
Additional InformationLazarus 2.1.0
FPC 3.0.4
x86_64-darwin-cocoa (beta)
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Relationships

related to 0034372 resolvedFlorian Internal error 2013121801 on build server 

Activities

Bart Broersma

2019-10-09 12:49

reporter   ~0118444

Last edited: 2019-10-09 12:51

View 2 revisions

Internal errors are alway compiler bugs.
Searching the bugtracker (project fpc) for the internal error number will easily find if that was already reported.

Moving to fpc.
Probably duplicate of 0034372

Cyrax

2019-10-09 21:47

reporter   ~0118455

Remove all unversioned files and try to rebuild Lazarus again.

Bart Broersma

2019-10-10 12:47

reporter   ~0118458

Category should be set to compiler (I didn't notice it was set to "[All Project] General" when I move it form Lazarus to fpc).

Hans Luijten

2019-10-10 12:53

reporter   ~0118459

Is this anything I can do?
Tried changing category, but either do not have the rights to do so, or there is not option to do this, or I'm not seeing it 😊

Bart Broersma

2019-10-13 12:12

reporter   ~0118556

@Hans: someone with developer status in the fpc section of the bugtracker can do that. Mere mortals like us can't ;-)

Hans Luijten

2019-10-13 12:48

reporter   ~0118559

Thanks Bart 😂

Jonas Maebe

2019-10-18 22:33

manager   ~0118670

I cannot reproduce it. I checked out revision 62009 of lazarus, and then successfully built it with FPC 3.0.4 and "make LCL_PLATFORM=cocoa CPU_TARGET=x86_64". Did it still not work after deleting all previously compiled units?

Marco van de Voort

2019-10-18 22:39

manager   ~0118672

Note that it would be very good information to know if this behaviour also happens with trunk, since no fixes are done anymore to the FPC 3.0.x series.

Hans Luijten

2019-10-19 10:10

reporter   ~0118680

Thanks Bart, Marco and Jonas for all the efforts.
I've tried to close this issue, since the problem seems to have gone away with newer version (Lazarus 2.1.0 r62054M FPC 3.0.4 x86_64-darwin-cocoa (beta) compiles just fine).
However I can't find a "Close" button - maybe because of my privileges here after the issue got moved to "compiler"?

@Jonas; I will keep that in mind to remove all old units. I usually do a "make LCL_PLATFORM=cocoa CPU_TARGET=x86_64 clean all".

Florian

2019-10-19 18:18

administrator   ~0118706

Closed based on discussion.

Issue History

Date Modified Username Field Change
2019-10-09 12:40 Hans Luijten New Issue
2019-10-09 12:48 Bart Broersma Relationship added related to 0034372
2019-10-09 12:49 Bart Broersma Summary IDE SVN 62009 fails to compile under Cocoa => IDE SVN 62009 fails to compile under Cocoa (Internal error 2013121801)
2019-10-09 12:49 Bart Broersma LazTarget => -
2019-10-09 12:49 Bart Broersma Widgetset Cocoa => Cocoa
2019-10-09 12:49 Bart Broersma Note Added: 0118444
2019-10-09 12:51 Bart Broersma Note Edited: 0118444 View Revisions
2019-10-09 12:51 Bart Broersma Project Lazarus => FPC
2019-10-09 12:51 Bart Broersma Category IDE => General
2019-10-09 21:47 Cyrax Note Added: 0118455
2019-10-10 12:47 Bart Broersma Note Added: 0118458
2019-10-10 12:53 Hans Luijten Note Added: 0118459
2019-10-12 23:43 Jonas Maebe Category General => Compiler
2019-10-12 23:43 Jonas Maebe Product Version 2.0.5 (SVN) =>
2019-10-12 23:43 Jonas Maebe FPCTarget => -
2019-10-13 12:12 Bart Broersma Note Added: 0118556
2019-10-13 12:48 Hans Luijten Note Added: 0118559
2019-10-18 22:33 Jonas Maebe Note Added: 0118670
2019-10-18 22:39 Marco van de Voort Note Added: 0118672
2019-10-19 10:10 Hans Luijten Note Added: 0118680
2019-10-19 18:18 Florian Assigned To => Florian
2019-10-19 18:18 Florian Status new => closed
2019-10-19 18:18 Florian Resolution open => unable to reproduce
2019-10-19 18:18 Florian Note Added: 0118706