View Issue Details

IDProjectCategoryView StatusLast Update
0036155LazarusOtherpublic2019-10-09 14:31
ReporterHans LuijtenAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformCocoaOSmacOSOS Version10.14.x
Product Version2.0.5 (SVN)Product Build62008 
Target VersionFixed in Version 
Summary0036155: fpDebug fails to compile (fpdbgdarwinclasses.pas)
DescriptionWhen rebuilding the IDE (62008) from within the IDE, I get an error ("result" undefined) in "components/fpdebug/fpdbgdarwinclasses.pas".
I have been unable to test SVN 62009, since this one fails to compile.

I'm only guessing here that this may have been a function in the past, however since "UpdateWatches64" is a procedure, so no return result would be send anyway.

This is the code that fails;

  if Process.Mode=dm32 then
    result := UpdateWatches32
  else
    result := UpdateWatches64;

Modifying it to:

  if Process.Mode=dm32 then
   UpdateWatches32
  else
   UpdateWatches64;

seems to fix this - but I honestly have no idea if this is the correct way to fix this issue.
Steps To Reproducesvn up
make LCL_PLATFORM=cocoa CPU_TARGET=x86_64

(works)

Start IDE, and choose "tools" - "Build Lazarus with ...".

(fails)
Additional InformationLazarus 2.1.0 r62008M
FPC 3.0.4
x86_64-darwin-cocoa (beta)

Possible fix, again not sure if this is the correct way to fix this:

Index: components/fpdebug/fpdbgdarwinclasses.pas
===================================================================
--- components/fpdebug/fpdbgdarwinclasses.pas (revision 62008)
+++ components/fpdebug/fpdbgdarwinclasses.pas (working copy)
@@ -428,9 +428,10 @@
     exit;
 
   if Process.Mode=dm32 then
- result := UpdateWatches32
+ UpdateWatches32
   else
- result := UpdateWatches64;
+ UpdateWatches64;
+
   FDebugStateChanged:=true;
 end;
TagsNo tags attached.
Fixed in Revision62009
LazTarget-
WidgetsetCocoa
Attached Files

Activities

Martin Friebe

2019-10-09 14:27

manager   ~0118445

Please test with 62009

Hans Luijten

2019-10-09 14:31

reporter   ~0118446

As stated in the description;
"I have been unable to test SVN 62009, since this one fails to compile."

Issue History

Date Modified Username Field Change
2019-10-09 12:59 Hans Luijten New Issue
2019-10-09 14:27 Martin Friebe Assigned To => Martin Friebe
2019-10-09 14:27 Martin Friebe Status new => resolved
2019-10-09 14:27 Martin Friebe Resolution open => fixed
2019-10-09 14:27 Martin Friebe Fixed in Revision => 62009
2019-10-09 14:27 Martin Friebe LazTarget => -
2019-10-09 14:27 Martin Friebe Widgetset Cocoa => Cocoa
2019-10-09 14:27 Martin Friebe Note Added: 0118445
2019-10-09 14:31 Hans Luijten Note Added: 0118446