View Issue Details

IDProjectCategoryView StatusLast Update
0036196FPCCompilerpublic2019-10-21 21:43
ReporterThaddy de KoningAssigned ToSven Barth 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformallOSallOS Versionall
Product Version3.3.1Product Build43225 
Target VersionFixed in Version3.3.1 
Summary0036196: ATTRIBUTES memory leaks in tests
Descriptiontest tcustomattr13.pp leaks memory

I suspect multiple attribute tests suffer the same issue
See also forum https://forum.lazarus.freepascal.org/index.php/topic,47111.0.html
Steps To ReproduceCompile tcustomattr13.pp with -glh
Outputs:

 fpc -glh tcustomattr13.pp
Free Pascal Compiler version 3.3.1-r43218-sysutils-patch [2019/10/18] for arm
Copyright (c) 1993-2019 by Florian Klaempfl and others
Target OS: Linux for ARMHF
Compiling tcustomattr13.pp
Linking tcustomattr13
188 lines compiled, 2.9 sec
asta@thaddyginaasta:~ $ ./tcustomattr13
3
CheckAttr1
137438953500.00003.1416
Heap dump by heaptrc unit of /home/asta/tcustomattr13
23 memory blocks allocated : 5614/5648
21 memory blocks freed : 1494/1528
2 unfreed memory blocks : 4120
True heap size : 425984
True free heap : 421648
Should be : 421672
Call trace for block $76EE33E0 size 4096
Call trace for block $76EC3680 size 24

Additional InformationA simple example I added on the forum does not leak, but I suppose that is by accident.
In the test suite, similar tests also probably fail
TagsNo tags attached.
Fixed in Revision43299
FPCOldBugId
FPCTarget-
Attached Files

Activities

Sven Barth

2019-10-21 21:43

manager   ~0118763

Please note that the memory leak in tcustomattr13 was not related to the attributes, but was due to the test itself. The problem where attributes that belonged to a property.

Please test and close if okay.

Issue History

Date Modified Username Field Change
2019-10-19 09:13 Thaddy de Koning New Issue
2019-10-21 21:43 Sven Barth Assigned To => Sven Barth
2019-10-21 21:43 Sven Barth Status new => resolved
2019-10-21 21:43 Sven Barth Resolution open => fixed
2019-10-21 21:43 Sven Barth Fixed in Version => 3.3.1
2019-10-21 21:43 Sven Barth Fixed in Revision => 43299
2019-10-21 21:43 Sven Barth FPCTarget => -
2019-10-21 21:43 Sven Barth Note Added: 0118763