View Issue Details

IDProjectCategoryView StatusLast Update
0036277LazarusIDEpublic2019-11-19 17:28
ReporterAlexey Tor.Assigned Towp 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformWin10 x64OSOS Version
Product Version2.1 (SVN)Product Build 
Target VersionFixed in Version 
Summary0036277: IDE Component Palette cannot show transparent BMP icons
DescriptionPackage ATFlatControls adds "AT Components" page with BMP icons.
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Activities

Alexey Tor.

2019-11-07 13:44

reporter  

ide-back.png (24,653 bytes)
ide-back.png (24,653 bytes)

wp

2019-11-07 15:19

developer   ~0119138

Cannot reproduce. Cloned your https://github.com/Alexey-T/ATFlatControls repository, installed in Laz trunk/32-bit and 64/bit - the icons are rendered correctly with transparent background (see my screenshot).

Please give more specific information.

And I'd appreciate if you'd create a small project (or component here) to demonstrate the issue. Not everybody wants to install a full third-party component package to solve an issue.

atflatcontrols.png (9,022 bytes)
atflatcontrols.png (9,022 bytes)

Alexey Tor.

2019-11-07 15:33

reporter   ~0119139

Free Pascal Compiler version 3.3.1-r43118 [2019/10/04] for i386
Maybe it depends on FPC?

wp

2019-11-07 15:41

developer   ~0119140

No, installed also on Laz trunk r62167/fpc trunk r43385. No problem either.

Zeljan Rikalo

2019-11-07 17:07

developer   ~0119141

Graphic card driver problem ?

wp

2019-11-18 23:57

developer   ~0119395

Any additional information from you, Alexey? Otherwise I'll resolve as "cannot reproduce"

Alexey Tor.

2019-11-19 10:34

reporter   ~0119398

no more information.

Issue History

Date Modified Username Field Change
2019-11-07 13:44 Alexey Tor. New Issue
2019-11-07 13:44 Alexey Tor. File Added: ide-back.png
2019-11-07 15:19 wp File Added: atflatcontrols.png
2019-11-07 15:19 wp Note Added: 0119138
2019-11-07 15:19 wp Assigned To => wp
2019-11-07 15:19 wp Status new => assigned
2019-11-07 15:19 wp Status assigned => feedback
2019-11-07 15:19 wp LazTarget => -
2019-11-07 15:33 Alexey Tor. Note Added: 0119139
2019-11-07 15:33 Alexey Tor. Status feedback => assigned
2019-11-07 15:41 wp Note Added: 0119140
2019-11-07 17:07 Zeljan Rikalo Note Added: 0119141
2019-11-18 23:57 wp Status assigned => feedback
2019-11-18 23:57 wp Note Added: 0119395
2019-11-19 10:34 Alexey Tor. Note Added: 0119398
2019-11-19 10:34 Alexey Tor. Status feedback => assigned
2019-11-19 17:28 wp Status assigned => resolved
2019-11-19 17:28 wp Resolution open => unable to reproduce