View Issue Details

IDProjectCategoryView StatusLast Update
0036278FPCFCLpublic2019-11-08 13:28
ReporterBernd KreussAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version3.0.4Product Build 
Target VersionFixed in Version3.3.1 
Summary0036278: TCSVDataset ignoring Delimiter
DescriptionTCSVDataset will only work with comma delimiter, setting a different delimiter has no effect.
Steps To Reproducewith the following test.csv:

foo;bar
42;23

This code:

  CSV := TCSVDataset.Create(self);
  CSV.CSVOptions.FirstLineAsFieldNames := True;
  CSV.CSVOptions.Delimiter := ';';
  CSV.CSVOptions.IgnoreOuterWhitespace := True;
  CSV.LoadFromCSVFile('test.csv');
  WriteLn(CSV.FieldCount);
  WriteLn(CSV.FieldDefs[0].Name);

will produce this output:
1
foo;bar

When I change my csv file to use commas then it will output
2
foo

Additional InformationSomehow the Information from CSVOptions is not properly propagated down to all the numerous csv parser and handler objects that are created further down the line, for example there is a TCVSHandler class somewhere deep down within it that seems to be initialized with hardcoded default separators, but I could not really debug it yet because I have not even partially understood how all this works internally and also my computer here at work does not have FPC with debug symbols installed and I can't afford to break my productive installation currently.
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget3.2.0
Attached Files

Activities

Bernd Kreuss

2019-11-07 14:36

reporter   ~0119134

Oh, after doing soem more research I see it has been fixed in trunk already, so this can be closed. Sorry.

Zeljan Rikalo

2019-11-07 14:40

reporter   ~0119135

Is it merged to fixes_3_2 ?

Marco van de Voort

2019-11-07 22:54

manager   ~0119151

I just checked, there are no unmerged revisions that match "csv", so assume merged. All fcl-base/ is merged

Michael Van Canneyt

2019-11-08 13:28

administrator   ~0119157

I checked with 3.2.0, it is fixed.

Issue History

Date Modified Username Field Change
2019-11-07 14:32 Bernd Kreuss New Issue
2019-11-07 14:36 Bernd Kreuss Note Added: 0119134
2019-11-07 14:40 Zeljan Rikalo Note Added: 0119135
2019-11-07 22:54 Marco van de Voort Note Added: 0119151
2019-11-08 13:28 Michael Van Canneyt Assigned To => Michael Van Canneyt
2019-11-08 13:28 Michael Van Canneyt Status new => resolved
2019-11-08 13:28 Michael Van Canneyt Resolution open => no change required
2019-11-08 13:28 Michael Van Canneyt Fixed in Version => 3.3.1
2019-11-08 13:28 Michael Van Canneyt FPCTarget => 3.2.0
2019-11-08 13:28 Michael Van Canneyt Note Added: 0119157