View Issue Details

IDProjectCategoryView StatusLast Update
0036361FPCFCLpublic2019-12-05 11:44
ReporterMarco van de VoortAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Platformwin32OSOS Version
Product Version3.3.1Product Build 
Target VersionFixed in Version3.3.1 
Summary0036361: csvdocument should used buffered filereader
Description(from a forum)

it was mentioned csvdocument was slow and a recommendation to change to a buffered filereader. I checked and it still uses plain tfilestream in trunk.

Since fcl-base has such bufferedstreams, maybe we should switch it?
TagsNo tags attached.
Fixed in Revision43641
FPCOldBugId
FPCTarget3.2.0
Attached Files

Activities

Michael Van Canneyt

2019-12-05 11:44

administrator   ~0119621

Added buffer stream reading for files , made buffer size settable in LoadFromFile (default 16k). Added test case

Issue History

Date Modified Username Field Change
2019-11-26 13:21 Marco van de Voort New Issue
2019-11-26 17:47 Michael Van Canneyt Assigned To => Michael Van Canneyt
2019-11-26 17:47 Michael Van Canneyt Status new => assigned
2019-12-05 11:44 Michael Van Canneyt Status assigned => resolved
2019-12-05 11:44 Michael Van Canneyt Resolution open => fixed
2019-12-05 11:44 Michael Van Canneyt Fixed in Version => 3.3.1
2019-12-05 11:44 Michael Van Canneyt Fixed in Revision => 43641
2019-12-05 11:44 Michael Van Canneyt FPCTarget => 3.2.0
2019-12-05 11:44 Michael Van Canneyt Note Added: 0119621