View Issue Details

IDProjectCategoryView StatusLast Update
0036378FPCCompilerpublic2020-01-21 15:16
ReporterJ. Gareth Moreton Assigned To 
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
PlatformCross-platformOSMicrosoft Windows 
Product Version3.3.1 
Fixed in Version3.3.1 
Summary0036378: Internal Error Number Clash (2019112401)
DescriptionTwo differently-triggered internal errors both carry the number 2019112401. One needs changing to 2019112403 (2019112402 is already in use elsewhere).
Steps To ReproduceN/A
Additional InformationIssue 0036377 is crashing with this internal error, and due to the number clash, narrowing down the cause is being made more difficult.
Tagscompiler, internal error
Fixed in Revision43610
FPCOldBugId
FPCTarget-
Attached Files

Relationships

related to 0036377 closedFlorian Unit name prefix causes internal error 2019112401 (Generics) 

Activities

Florian

2019-11-29 22:07

administrator   ~0119550

I fixed it.

J. Gareth Moreton

2020-01-21 15:16

developer   ~0120605

Number clash fixed.

Issue History

Date Modified Username Field Change
2019-11-29 02:23 J. Gareth Moreton New Issue
2019-11-29 02:24 J. Gareth Moreton Relationship added related to 0036377
2019-11-29 02:24 J. Gareth Moreton Tag Attached: compiler
2019-11-29 02:24 J. Gareth Moreton Tag Attached: internal error
2019-11-29 22:07 Florian Assigned To => Florian
2019-11-29 22:07 Florian Status new => resolved
2019-11-29 22:07 Florian Resolution open => fixed
2019-11-29 22:07 Florian Fixed in Version => 3.3.1
2019-11-29 22:07 Florian Fixed in Revision => 43610
2019-11-29 22:07 Florian FPCTarget => -
2019-11-29 22:07 Florian Note Added: 0119550
2020-01-21 15:16 J. Gareth Moreton Assigned To Florian =>
2020-01-21 15:16 J. Gareth Moreton Status resolved => closed
2020-01-21 15:16 J. Gareth Moreton Note Added: 0120605