View Issue Details

IDProjectCategoryView StatusLast Update
0036391FPCCompilerpublic2019-12-04 12:32
ReporterThaddy de KoningAssigned ToJ. Gareth Moreton 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformarmhfOSRaspbianOS VersionBuster
Product Version3.3.1Product Build43626 
Target VersionFixed in Version 
Summary0036391: Compiler fails to build
DescriptionThe compiler fails to build for armhf/Raspbian on r43626

Build fails in *first* cycle on pp.pas
Steps To Reproducemake clean all install.
Hang is on:
/usr/bin/ppcarm -Ur -Xs -O2 -n -Fuarm -Fusystems -Fu/home/asta/fpc331/rtl/units/arm-linux -Fiarm -FEarm/bin/arm-linux -FUarm/units/arm-linux -dRELEASE -CX -XXs -CpARMv7a -CfVFPv3 -OpARMv7a -dREVINC -darm -dGDB -dBROWSERLOG -Fuarmgen pp.pas
Additional InformationFull build settings:
sudo make clean install INSTALL_PREFIX=/usr/local PP=/usr/bin/ppcarm REVINC=force REVSTR=43626 OPT="-CX -XXs -CpARMv7a -CfVFPv3 -OpARMv7a"

bootstrap is 3.0.4 (native)
TagsNo tags attached.
Fixed in Revision43635
FPCOldBugId
FPCTarget-
Attached Files

Activities

Thaddy de Koning

2019-12-02 15:33

reporter   ~0119587

Last edited: 2019-12-02 15:36

View 2 revisions

sudo make clean install
or
sudo make clean all install

Does not make a difference. One core is maxed out in endless loop:
Top output:
 root 20 0 54880 54208 2840 R 99.7 6.1 3:30.50 ppcarm

Thaddy de Koning

2019-12-02 15:40

reporter   ~0119588

The above is on RPi3, but a quick repeat on a RPi 4 hangs in the same way.

Thaddy de Koning

2019-12-02 20:38

reporter   ~0119594

Last working version: Free Pascal Compiler version 3.3.1-r43614 [2019/11/30] for arm

Sven Barth

2019-12-02 21:45

manager   ~0119596

I can't reproduce while cross compiling. Would you please try to bisect the revision? It's only 12 revisions after all...

Thaddy de Koning

2019-12-03 07:45

reporter   ~0119601

And I have time on my hand... ;) (true) Will tr y to see where exactly. At least 43663 still does not work. Building a cross compiler works indeed - at least the build completes, but a native armhf compiler still fails

Thaddy de Koning

2019-12-04 09:31

reporter   ~0119607

This is fixed. Plz close. r43635 compiles

J. Gareth Moreton

2019-12-04 12:32

developer   ~0119610

Marked as resolved according to reporter's feedback.

Issue History

Date Modified Username Field Change
2019-12-02 15:30 Thaddy de Koning New Issue
2019-12-02 15:33 Thaddy de Koning Note Added: 0119587
2019-12-02 15:36 Thaddy de Koning Note Edited: 0119587 View Revisions
2019-12-02 15:40 Thaddy de Koning Note Added: 0119588
2019-12-02 18:29 J. Gareth Moreton Priority normal => urgent
2019-12-02 18:29 J. Gareth Moreton Severity minor => major
2019-12-02 18:29 J. Gareth Moreton FPCTarget => -
2019-12-02 20:38 Thaddy de Koning Note Added: 0119594
2019-12-02 21:45 Sven Barth Note Added: 0119596
2019-12-03 07:45 Thaddy de Koning Note Added: 0119601
2019-12-04 09:31 Thaddy de Koning Note Added: 0119607
2019-12-04 12:32 J. Gareth Moreton Assigned To => J. Gareth Moreton
2019-12-04 12:32 J. Gareth Moreton Status new => resolved
2019-12-04 12:32 J. Gareth Moreton Resolution open => fixed
2019-12-04 12:32 J. Gareth Moreton Fixed in Revision => 43635
2019-12-04 12:32 J. Gareth Moreton Note Added: 0119610