View Issue Details

IDProjectCategoryView StatusLast Update
0036394FPCfpReportpublic2019-12-04 07:58
ReporterAndi FriessAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformDell XPSOSWin10 / 64 ProOS VersionWin10 / 64 Pro
Product Version3.3.1Product Build 
Target VersionFixed in Version3.3.1 
Summary0036394: fcl-report is not compiled by default (make all install) (win x86_64-win64)
DescriptionIf i make a 'all install' fcl-report is not compiled and no ppu for fcl-report are found. Programms using fpreport claims about this (Eg. Lazarus with package fpreport).

In the units\x86_64-win64 i found nearly all fcl-* except fcl-report.
Steps To ReproduceD:\data\lazdev\work64ft\fpcbootstrap\make.exe --jobs=1 PP=D:\data\lazdev\work64ft\fpcbootstrap\ppcx64.exe FPCMAKE=D:\data\lazdev\work64ft\fpc\bin\x86_64-win64\fpcmake.exe PPUMOVE=D:\data\lazdev\work64ft\fpc\bin\x86_64-win64\ppumove.exe FPCDIR=D:\data\lazdev\work64ft\fpcsrc INSTALL_PREFIX=D:\data\lazdev\work64ft\fpc UPXPROG=echo COPYTREE=echo OS_SOURCE=win64 CPU_SOURCE=x86_64 OS_TARGET=win64 CPU_TARGET=x86_64 REVSTR=43622 REVINC=force "OPT=-vw-n-h-l-d-u-t-p-c- -dFPC_SOFT_FPUX80" --directory=D:\data\lazdev\work64ft\fpcsrc all install
TagsNo tags attached.
Fixed in Revision43630
FPCOldBugId
FPCTarget3.2.0
Attached Files

Activities

Michael Van Canneyt

2019-12-02 22:38

administrator   ~0119598

Hm. I will look into this.
If I recall correctly this was due to problems with the freetype dll, but I would need to check again, because this dependency was removed.

Michael Van Canneyt

2019-12-03 00:01

administrator   ~0119600

Compilation seems to be going fine. Enabled compile/install for Win64.

Andi Friess

2019-12-04 07:58

reporter   ~0119606

thx

Issue History

Date Modified Username Field Change
2019-12-02 22:32 Andi Friess New Issue
2019-12-02 22:32 Andi Friess Status new => assigned
2019-12-02 22:32 Andi Friess Assigned To => Michael Van Canneyt
2019-12-02 22:38 Michael Van Canneyt Note Added: 0119598
2019-12-03 00:01 Michael Van Canneyt Status assigned => resolved
2019-12-03 00:01 Michael Van Canneyt Resolution open => fixed
2019-12-03 00:01 Michael Van Canneyt Fixed in Version => 3.3.1
2019-12-03 00:01 Michael Van Canneyt Fixed in Revision => 43630
2019-12-03 00:01 Michael Van Canneyt FPCTarget => 3.2.0
2019-12-03 00:01 Michael Van Canneyt Note Added: 0119600
2019-12-04 07:58 Andi Friess Status resolved => closed
2019-12-04 07:58 Andi Friess Note Added: 0119606