View Issue Details

IDProjectCategoryView StatusLast Update
0036434LazarusWidgetsetpublic2019-12-14 13:49
ReporterChris RordenAssigned ToJuha Manninen 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionnot fixable 
PlatformIntel 4770kOSUbuntuOS Version19.10
Product Version2.1 (SVN)Product Build62382 
Target VersionFixed in Version 
Summary0036434: QT5: GTK dependency
DescriptionI was surprised that a QT5 executable requires a GTK library. When launch a QT5 app on Ubuntu it complains
  Gtk-Message: 13:03:55.616: Failed to load module "appmenu-gtk-module"
(though it seems to run fine). Running
  sudo apt-get install appmenu-gtk3-module
removes the warning. I am just confused why a QT5 application expects a GTK module.
Steps To ReproduceBuild application in Lazarus, set to QT5 widgetset, compile and run. Examine command line output for error.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetQT5
Attached Files

Relationships

related to 0036359 new Simple project with gtk2 widget set hangs on startup 

Activities

Chris Rorden

2019-12-13 19:11

reporter  

qt5.zip (109,088 bytes)

Juha Manninen

2019-12-13 23:17

developer   ~0119829

Last edited: 2019-12-13 23:18

View 2 revisions

It is a problem with Ubuntu 19.10. That's what you have, right?
Lazarus does not depend on any appmenu module. Somehow Ubuntu creates that requirement.
With GTK2 bindings an application (or Lazarus itself) also hangs. Please see the related issue.

Ubuntu should add a dependency for the appmenu module into their Lazarus package. The workaround can be explained in wiki. In forum there was a discussion. See the related issue.
I guess this will be resolved as "not fixable".

Zeljan Rikalo

2019-12-14 09:24

developer   ~0119832

That's because Qt5 gtk theme really uses gtk(2,3) (implemented by Qt5 lib not by lcl). There's nothing to fix by us, so pls close.

Chris Rorden

2019-12-14 13:49

reporter   ~0119838

OK, That makes perfect sense and explains why the warning did not impact performance. Thanks for your rapid feedback.

Issue History

Date Modified Username Field Change
2019-12-13 19:11 Chris Rorden New Issue
2019-12-13 19:11 Chris Rorden File Added: qt5.zip
2019-12-13 23:08 Juha Manninen Relationship added related to 0036359
2019-12-13 23:09 Juha Manninen Assigned To => Juha Manninen
2019-12-13 23:09 Juha Manninen Status new => assigned
2019-12-13 23:17 Juha Manninen Note Added: 0119829
2019-12-13 23:18 Juha Manninen Note Edited: 0119829 View Revisions
2019-12-14 09:24 Zeljan Rikalo Status assigned => resolved
2019-12-14 09:24 Zeljan Rikalo Resolution open => no change required
2019-12-14 09:24 Zeljan Rikalo LazTarget => -
2019-12-14 09:24 Zeljan Rikalo Widgetset QT5 => QT5
2019-12-14 09:24 Zeljan Rikalo Note Added: 0119832
2019-12-14 12:07 Juha Manninen Resolution no change required => not fixable
2019-12-14 12:07 Juha Manninen Widgetset QT5 => QT5
2019-12-14 13:49 Chris Rorden Status resolved => closed
2019-12-14 13:49 Chris Rorden Note Added: 0119838