View Issue Details

IDProjectCategoryView StatusLast Update
0036441LazarusWidgetsetpublic2019-12-15 12:52
ReporterChris Rorden Assigned ToBart Broersma  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
PlatformSystem76 Oryx ProOSUbuntu 
Product Version2.1 (SVN) 
Summary0036441: GTK3: Crash when string assigned to clipboard
DescriptionGTK3 crashes when text string is copied to clipboard.
Steps To Reproduceuses clipbrd;

procedure TForm1.Button1Click(Sender: TObject);
begin
  ClipBoard.AsText:= 'hello world';
end;
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetGTK 3
Attached Files

Relationships

duplicate of 0036348 resolvedJuha Manninen gtk3: Clipboard.AsText crash 

Activities

CudaText man

2019-12-14 21:39

reporter   ~0119851

Last edited: 2019-12-14 23:29

View 2 revisions

Duplicate 0036348

Chris Rorden

2019-12-15 12:52

reporter   ~0119853

Sorry I missed the duplicate

Issue History

Date Modified Username Field Change
2019-12-14 21:36 Chris Rorden New Issue
2019-12-14 21:39 CudaText man Note Added: 0119851
2019-12-14 23:29 Bart Broersma Note Edited: 0119851 View Revisions
2019-12-14 23:29 Bart Broersma Assigned To => Bart Broersma
2019-12-14 23:29 Bart Broersma Status new => resolved
2019-12-14 23:29 Bart Broersma Resolution open => duplicate
2019-12-14 23:29 Bart Broersma LazTarget => -
2019-12-14 23:29 Bart Broersma Widgetset GTK 3 => GTK 3
2019-12-14 23:29 Bart Broersma Relationship added duplicate of 0036348
2019-12-15 12:52 Chris Rorden Status resolved => closed
2019-12-15 12:52 Chris Rorden Note Added: 0119853