View Issue Details

IDProjectCategoryView StatusLast Update
0036481LazarusLazUtilspublic2020-01-03 10:25
ReporterOndrej PokornyAssigned ToOndrej Pokorny 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.1 (SVN)Product Build 
Target Version2.2Fixed in Version 
Summary0036481: ANSI ODBC regression - strings are read in wrong encoding
Descriptionr61976 changed ANSI GetStandardCodePageProc result. Now it is UTF-8 in Lazarus and not WIN-ANSI.

As a result, all ANSI strings that are read from 3rd party libraries and interfaces are corrupt.
Steps To ReproduceSee the attached project. Compile with FPC trunk because it has ODBC encoding fixes that are not present in FPC stable.
Additional Informationr61976 broke this. Before r61976 the result was correct.
TagsNo tags attached.
Fixed in Revision62474
LazTarget-
Widgetset
Attached Files

Relationships

related to 0036480 closedOndrej Pokorny TEncoding.ANSI regression - it's UTF-8 now in Lazarus 

Activities

Ondrej Pokorny

2019-12-26 14:27

developer  

ODBC-regression.png (7,791 bytes)
ODBC-regression.png (7,791 bytes)

Ondrej Pokorny

2019-12-26 14:28

developer  

ODBCTest.lpr (892 bytes)

Bart Broersma

2019-12-26 15:51

developer   ~0120072

Isn't this caused by the same reason you mentioned in 0036480?

Ondrej Pokorny

2019-12-26 15:54

developer   ~0120073

@Bart: yes. In both reports I document r61976 as the reason.

Issue History

Date Modified Username Field Change
2019-12-26 14:27 Ondrej Pokorny New Issue
2019-12-26 14:27 Ondrej Pokorny File Added: ODBC-regression.png
2019-12-26 14:28 Ondrej Pokorny File Added: ODBCTest.lpr
2019-12-26 15:50 Bart Broersma Relationship added related to 0036480
2019-12-26 15:51 Bart Broersma Note Added: 0120072
2019-12-26 15:54 Ondrej Pokorny Note Added: 0120073
2020-01-03 10:25 Ondrej Pokorny Assigned To => Ondrej Pokorny
2020-01-03 10:25 Ondrej Pokorny Status new => assigned
2020-01-03 10:25 Ondrej Pokorny Status assigned => resolved
2020-01-03 10:25 Ondrej Pokorny Resolution open => fixed
2020-01-03 10:25 Ondrej Pokorny Fixed in Revision => 62474
2020-01-03 10:25 Ondrej Pokorny LazTarget => -
2020-01-03 10:25 Ondrej Pokorny Status resolved => closed