View Issue Details

IDProjectCategoryView StatusLast Update
0036482FPCPackagespublic2020-05-18 20:20
ReporterCudaText man Assigned ToMichael Van Canneyt  
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionreopened 
Product Version3.3.1 
Fixed in Version3.3.1 
Summary0036482: Reworked TRegExpr
DescriptionI 've made many patches. See full log-- at official Github of A.Sorokin--
https://github.com/andgineer/TRegExpr/blob/master/History.txt
No need to mention changes here, history shows them.
TagsNo tags attached.
Fixed in Revision43972
FPCOldBugId
FPCTarget3.2.0
Attached Files

Relationships

related to 0035438 resolvedMichael Van Canneyt bug in regexpr in procedure TRegExpr.Split / returns empty tstrings 

Activities

CudaText man

2019-12-26 14:54

reporter   ~0120071

Download:
https://github.com/andgineer/TRegExpr

Michael Van Canneyt

2019-12-27 11:49

administrator   ~0120083

Please provide exact patches to our version of regexp.pas.

The diff is bigger than the original file, there is no way we can check what you did.
We also did changes to the regexpr unit, there is no way to check if you are undoing these changes with your patch.

CudaText man

2020-01-14 16:53

reporter   ~0120437

Last edited: 2020-01-14 16:54

View 2 revisions

>We also did changes to the regexpr unit, there is no way to check if you are undoing these changes with your patch.

I made some more patches to Sorokin's Github repo.
Before I began making patches in Github, Sorokin took all last changes to RegExpr from FPC repo - for ex he took the patch which added "\n" handling in Substitute method, so all FPC changes all already there. My patches don't break stuff. One minor thing: before, regex "dd{" was considered OK, and now it is not ok (RegExpr will give new error code about broken {} braces).

I added lot of things and lot of optimizations (small and one big).

I reformatted entire regexpr.pas via Delphi Formatter.exe so the whole file was changed.

CudaText man

2020-01-14 16:57

reporter   ~0120439

The biggest optimization
https://github.com/andgineer/TRegExpr/issues/129

Michael Van Canneyt

2020-01-18 16:38

administrator   ~0120516

Fixed. Fixed some compiler warnings (initializing some consts, removing unused consts)

Note that I removed most defines in a backwards compatible way.
They're of no use since most people use the precompiled version.
Next time when you submit a patch to the upstream regepr, send the same patch here, please.

People that really need the defines can use the upstream version and set the defines anyway they want.

Issue History

Date Modified Username Field Change
2019-12-26 14:54 CudaText man New Issue
2019-12-26 14:54 CudaText man Note Added: 0120071
2019-12-27 11:49 Michael Van Canneyt Assigned To => Michael Van Canneyt
2019-12-27 11:49 Michael Van Canneyt Status new => resolved
2019-12-27 11:49 Michael Van Canneyt Resolution open => won't fix
2019-12-27 11:49 Michael Van Canneyt FPCTarget => -
2019-12-27 11:49 Michael Van Canneyt Note Added: 0120083
2020-01-14 16:53 CudaText man Status resolved => feedback
2020-01-14 16:53 CudaText man Resolution won't fix => reopened
2020-01-14 16:53 CudaText man Note Added: 0120437
2020-01-14 16:54 CudaText man Note Edited: 0120437 View Revisions
2020-01-14 16:57 CudaText man Note Added: 0120439
2020-01-14 16:57 CudaText man Status feedback => assigned
2020-01-18 16:38 Michael Van Canneyt Status assigned => resolved
2020-01-18 16:38 Michael Van Canneyt Fixed in Version => 3.3.1
2020-01-18 16:38 Michael Van Canneyt Fixed in Revision => 43972
2020-01-18 16:38 Michael Van Canneyt FPCTarget - => 3.2.0
2020-01-18 16:38 Michael Van Canneyt Note Added: 0120516
2020-01-18 16:39 Michael Van Canneyt Relationship added related to 0035438