View Issue Details

IDProjectCategoryView StatusLast Update
0036491LazarusWidgetsetpublic2020-01-05 08:55
ReporterDr. Bodo Wittig Assigned ToDmitry Boyarintsev  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformiMac 27" / MacBook AirOSMacOS 
Product Version2.0.6 
Summary0036491: Grid DblClick problem - application hangs
DescriptionI'm a developing a typical master/detail view with a grid on the left side and detail view on the right side of the form. Standard is the grid enabled and the detail view readonly. When doubleclicking on one of the grid entries, the program should react in the OnDblClick Event as follows: set the focus on the edit field of the detailview and disable the grid as long as the user does not click the button to indicate, that detail editing is ready to save and give control back to the grid.

In reality the focus is set to the edit field as expected, the grid gets disabled as expected but the button cannot be clicked and is not drawn like an disabled button. Same happens, if there are more clickable controls like radio buttons. Edit fields seem to be the only ones, which can be used. The effect is, that the application hangs, since nothing reacts to a click.

This is a macOS Cocoa 64bit only problem. I checked it with Lazarus 2.0.2 / i386 / carbon and everything was running as expected

See demo.
Steps To ReproduceCompile, build and start. Doubleclick on any item of the grid and try to click the button.
TagsNo tags attached.
Fixed in Revision62500
LazTarget-
WidgetsetCocoa
Attached Files

Activities

Dr. Bodo Wittig

2019-12-29 08:36

reporter  

Test GridDBLClick.zip (133,666 bytes)

Dmitry Boyarintsev

2020-01-05 08:55

developer   ~0120226

The actual issue is not with a double-click, but rather with Disabling the StringGrid.
While the control was disabled, the enforced CAPTURE of the mouse event was not released.

Please test and close if ok

Issue History

Date Modified Username Field Change
2019-12-29 08:36 Dr. Bodo Wittig New Issue
2019-12-29 08:36 Dr. Bodo Wittig File Added: Test GridDBLClick.zip
2020-01-03 01:36 Dmitry Boyarintsev Assigned To => Dmitry Boyarintsev
2020-01-03 01:36 Dmitry Boyarintsev Status new => assigned
2020-01-05 08:55 Dmitry Boyarintsev Status assigned => resolved
2020-01-05 08:55 Dmitry Boyarintsev Resolution open => fixed
2020-01-05 08:55 Dmitry Boyarintsev Fixed in Revision => 62500
2020-01-05 08:55 Dmitry Boyarintsev LazTarget => -
2020-01-05 08:55 Dmitry Boyarintsev Widgetset Cocoa => Cocoa
2020-01-05 08:55 Dmitry Boyarintsev Note Added: 0120226