View Issue Details

IDProjectCategoryView StatusLast Update
0036530FPCCompilerpublic2020-01-19 22:45
ReporterJ. Gareth MoretonAssigned ToFlorian 
PriorityurgentSeverityblockReproducibilityalways
Status closedResolutionfixed 
Platformi386 and x86_64OSMicrosoft WindowsOS Version10 Professional
Product Version3.3.1Product Buildr43880 
Target VersionFixed in Version3.3.1 
Summary0036530: FPC does not build with -Os option
DescriptionAs of revision r43880, the Free Pascal Compiler does not build under i386 and x86_64, failing at the ppc2 stage with access violations.

e.g. from i386-win32:

C:/Users/NLO-012/Documents/Programming/fpc/compiler/ppc2.exe -Ur -Xs -O2 -n -Fi../inc -Fi../i386 -Fi../win -FE. -FUC:/Users/NLO-012/Documents/Programming/fpc/rtl/units/i386-win32 -Os -di386 -dRELEASE -Us -Sg system.pp -Fi../win
system.pp(132,4) Error: Compilation raised exception internally
Fatal: Compilation aborted
An unhandled exception occurred at $004879F9:
EAccessViolation: Access violation
  $004879F9
  $00479C8B
  $004CAB19
  $004CCB99
  $004CD024
  $00434D72
  $00413E55

An unhandled exception occurred at $00419A11:
EAccessViolation: Access violation
  $00419A11
  $00419A9A
  $0040BC61
  $77458DA2
  $77458D74
  $77444216
  $00479C8B
  $004CAB19
  $004CCB99
  $004CD024
  $00434D72
  $00413E55
Steps To ReproducePull a fresh copy of the SVN trunk (r43880 or r43881) and attempt to run "make clean all install OPT=-Os"
Additional InformationPersonally confirmed broken for i386-win32, x86_64-win64, i386-linux and x86_64-linux (the last two via Ubuntu).
Tagsaccess violation, compiler, i386, linux, windows, x86, x86_64
Fixed in Revision43888
FPCOldBugId
FPCTarget-
Attached Files

Activities

J. Gareth Moreton

2020-01-07 20:48

developer   ~0120253

This is personally a block for me, since some of my optimisation work is only applicable when optimising for size.

Possibly related to 0036382

J. Gareth Moreton

2020-01-19 22:45

developer   ~0120565

FPC certainly does build with -Os now.

Issue History

Date Modified Username Field Change
2020-01-07 20:47 J. Gareth Moreton New Issue
2020-01-07 20:48 J. Gareth Moreton Priority normal => urgent
2020-01-07 20:48 J. Gareth Moreton Severity minor => block
2020-01-07 20:48 J. Gareth Moreton FPCTarget => -
2020-01-07 20:48 J. Gareth Moreton Note Added: 0120253
2020-01-07 20:49 J. Gareth Moreton Tag Attached: compiler
2020-01-07 20:49 J. Gareth Moreton Tag Attached: windows
2020-01-07 20:49 J. Gareth Moreton Tag Attached: linux
2020-01-07 20:49 J. Gareth Moreton Tag Attached: i386
2020-01-07 20:49 J. Gareth Moreton Tag Attached: x86
2020-01-07 20:49 J. Gareth Moreton Tag Attached: x86_64
2020-01-07 20:49 J. Gareth Moreton Tag Attached: access violation
2020-01-07 22:46 Florian Assigned To => Florian
2020-01-07 22:46 Florian Status new => resolved
2020-01-07 22:46 Florian Resolution open => fixed
2020-01-07 22:46 Florian Fixed in Version => 3.3.1
2020-01-07 22:46 Florian Fixed in Revision => 43888
2020-01-19 22:45 J. Gareth Moreton Status resolved => closed
2020-01-19 22:45 J. Gareth Moreton Note Added: 0120565