View Issue Details

IDProjectCategoryView StatusLast Update
0036577Lazarus CCRPackagespublic2020-01-22 13:12
ReporterHartmut Assigned ToDmitry Boyarintsev  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionreopened 
PlatformLinuxOSUbuntu 
Summary0036577: RichMemo: bugs handling German special characters (Ä Ö Ü ä ö ü ß)
DescriptionThe way in which RichMemo handles German special characters (Ä Ö Ü ä ö ü ß) is not compatible with Wordpad on Windows.

1) I created a RTF-file, which contains German special characters, with Wordpad on Windows. When I open this file with RichMemo, this characters are completely missing (not displayed).

2) I created a RTF-file, which contains German special characters, with RichMemo. When I open this file with Wordpad on Windows, every 2nd character after a German special character is missing (not displayed).
Steps To Reproduce1) Open attached file "Wordpad.rtf" (which was created by Wordpad on Windows) with RichMemo.
It looks like RichMemo_Editor.png
But it should look like Wordpad.png
 - the 7 German special characters are missing completely, only the blanks between them are shown
 
2) Attached file "RichMemo_Umlaute.rtf" was created by RichMemo.
It looked like RichMemo_Umlaute.png
But if you open it with Wordpad on Windows it looks like RichMemo_Umlaute_Wordpad.png
 - in the 3rd line the Blanks between the German special characters and the ending <"> are missing
 - in the 4th line the letters between the German special characters are missing
Additional InformationI tested with r7280.
For me it would be essential, that I can use (view and edit) the same RTF-files
 - on Windows 7 with Wordpad
 - on Linux (Ubuntu 18.04) with RichMemo
and that they appear compatible.
TagsNo tags attached.
WidgetsetGTK 2
Attached Files

Activities

Hartmut

2020-01-14 18:58

reporter  

Wordpad.rtf (1,047 bytes)   
{\rtf1\ansi\ansicpg1252\deff0\deflang1031{\fonttbl{\f0\fnil\fcharset0 Arial;}{\f1\fnil\fcharset0 Courier New;}{\f2\fnil\fcharset2 Symbol;}}
{\colortbl ;\red255\green0\blue0;}
{\*\generator Msftedit 5.41.21.2510;}\viewkind4\uc1\pard\sl240\slmult1\lang7\fs22 This RTF file was created by Wordpad on Windows 7 and is compatible with Wordpad on Windows XP.\par
\ul Only this line is underlined.\ulnone\par
\cf1 Only this line has a red text color.\cf0\par
\f1 Only this line is in Courier New, the rest is Arial.\f0\par
\par
This line contains 7 German special characters: "\'c4 \'d6 \'dc \'e4 \'f6 \'fc \'df".\par
\par
\pard{\pntext\f2\'B7\tab}{\*\pn\pnlvlblt\pnf2\pnindent0{\pntxtb\'B7}}\fi-284\li426\sl240\slmult1 This is the 1st line of a bullets list.\par
{\pntext\f2\'B7\tab}This is the 2nd line of a bullets list.\par
{\pntext\f2\'B7\tab}This is the 3rd line of a bullets list and so long, that if the text window is narrow enough, it must indented correctly under the beginning of the above lines.\par
\pard\sl240\slmult1\par
}
Wordpad.rtf (1,047 bytes)   
RichMemo_Editor.png (35,720 bytes)   
RichMemo_Editor.png (35,720 bytes)   
Wordpad.png (60,250 bytes)   
Wordpad.png (60,250 bytes)   
RichMemo_Umlaute.rtf (759 bytes)   
{\rtf1\ansi\ansicp1252\deff0\deflan1033{\fonttbl{\f0\fcharset0 Arial;}{\f1\fcharset0 Courier New;}{\f2\fcharset0 Noto Sans;}}{\colortbl;\red35\green38\blue39;}\f0\fs22\ulnone\cf1 \pard\li0\sl200\slmult1 This is the first line\f0\fs22  in Arial\f0\fs22 .\f0\fs22 \par \f0\fs22 \pard\li0\sl200\slmult1 This line contains 7 German special characters: "\u196  \u214  \u220  \u228  \u246  \u252  \u223 " in Arial.\f0\fs22 \par \f1\fs22 \pard\li0\sl200\slmult1 This line contains 7 German special characters: "\u196  \u214  \u220  \u228  \u246  \u252  \u223 " in Courier New.\f2\fs20 \par \f0\fs22 \pard\li0\sl200\slmult1 This line contains 7 German special characters with normal letters between: "\u196 a\u214 o\u220 u\u228 A\u246 O\u252 U\u223 s".\f2\fs20 \par }
RichMemo_Umlaute.rtf (759 bytes)   
RichMemo_Umlaute.png (26,292 bytes)   
RichMemo_Umlaute.png (26,292 bytes)   
RichMemo_Umlaute_Wordpad.png (56,522 bytes)   
RichMemo_Umlaute_Wordpad.png (56,522 bytes)   

Dmitry Boyarintsev

2020-01-17 17:09

developer   ~0120498

the issue is fixed in r7291
please test and close if ok

Hartmut

2020-01-18 16:35

reporter   ~0120515

I tested with r7297. Problem 1) was fixed perfectly. Thanks a lot.

Problem 2) is exactly the same as before:
Attached file "RichMemo_Umlaute2.rtf" was newly created by RichMemo r7297.
It looked like RichMemo_Umlaute2.png
But if you open it with Wordpad on Windows it looks like RichMemo_Umlaute2_Wordpad.png
 - in the 3rd line the Blanks between the German special characters and the ending <"> are missing
 - in the 4th line the letters between the German special characters are missing
 
If you don't have Windows to test this, you can use "wine wordpad" on Linux to test this (I used Ubuntu 18.04). It shows exactly the same issues (see RichMemo_Umlaute2_Wine_Wordpad.png) as Wordpad on Windows.

Hartmut

2020-01-18 16:38

reporter  

RichMemo_Umlaute2.rtf (670 bytes)   
{\rtf1\ansi\ansicp1252\deff0\deflan1033{\fonttbl{\f0\fcharset0 Arial;}{\f1\fcharset0 Courier New;}}{\colortbl;\red35\green38\blue39;}\f0\fs22\ulnone\cf1 \pard\li0\sl200\slmult1 This is the first line in Arial.\par \pard\li0\sl200\slmult1 This line contains 7 German special characters: "\u196  \u214  \u220  \u228  \u246  \u252  \u223 " in Arial.\par \f1\fs22 \pard\li0\sl200\slmult1 This line contains 7 German special characters: "\u196  \u214  \u220  \u228  \u246  \u252  \u223 " in Courier New.\f0\fs22 \par \pard\li0\sl200\slmult1 This line contains 7 German special characters with normal letters between: "\u196 a\u214 o\u220 u\u228 A\u246 O\u252 U\u223 s".\par }
RichMemo_Umlaute2.rtf (670 bytes)   
RichMemo_Umlaute2.png (25,777 bytes)   
RichMemo_Umlaute2.png (25,777 bytes)   
RichMemo_Umlaute2_Wordpad.png (54,478 bytes)   
RichMemo_Umlaute2_Wordpad.png (54,478 bytes)   

Hartmut

2020-01-18 16:50

reporter   ~0120519

If you open "RichMemo_Umlaute2.rtf" in LibreOffice 6.0.7.3 on Linux, the same issues are displayed.

Dmitry Boyarintsev

2020-01-18 20:52

developer   ~0120522

r7298
please test and close if ok

Hartmut

2020-01-19 12:00

reporter   ~0120542

I tested with r7299. Problem 2) is exactly the same as before. Sorry, nothing has changed.

Attached file "RichMemo_Umlaute3.rtf" was newly created by RichMemo r7299.
It looked like RichMemo_Umlaute3.png
But if you open it with Wordpad on Windows, it looks like RichMemo_Umlaute3_Wordpad.png
 - in the 3rd line the Blanks between the German special characters and the ending <"> are missing
 - in the 4th line the letters between the German special characters are missing

Exactly the same issues are shown in LibreOffice 6.0.7.3 on Linux, see RichMemo_Umlaute3_LibreOffice.png

Please test the next fix by yourself before you publish it.

To make this easy for you, I attached the used text in RichMemo_Umlaute.txt
You must only format it with Arial 11 respectively Courier New 11.
If you don't have Windows with Wordpad to test, you can use on Linux LibreOffice or "wine wordpad".
Thanks.

Hartmut

2020-01-19 12:01

reporter  

RichMemo_Umlaute3.rtf (680 bytes)   
{\rtf1\ansi\ansicp1252\deff0\deflan1033{\fonttbl{\f0\fcharset0 Arial;}{\f1\fcharset0 Courier New;}}{\colortbl;\red35\green38\blue39;}\f0\fs22\ulnone\cf1 \pard\li0\sl200\slmult1 This file was created with RichMemo r7299.\par \pard\li0\sl200\slmult1 This line contains 7 German special characters: "\u196  \u214  \u220  \u228  \u246  \u252  \u223 " in Arial.\par \f1\fs22 \pard\li0\sl200\slmult1 This line contains 7 German special characters: "\u196  \u214  \u220  \u228  \u246  \u252  \u223 " in Courier New.\f0\fs22 \par \pard\li0\sl200\slmult1 This line contains 7 German special characters with normal letters between: "\u196 a\u214 o\u220 u\u228 A\u246 O\u252 U\u223 S".\par }
RichMemo_Umlaute3.rtf (680 bytes)   
RichMemo_Umlaute3.png (27,518 bytes)   
RichMemo_Umlaute3.png (27,518 bytes)   
RichMemo_Umlaute3_Wordpad.png (52,809 bytes)   
RichMemo_Umlaute3_Wordpad.png (52,809 bytes)   
RichMemo_Umlaute.txt (295 bytes)   
This file was created with RichMemo r????.
This line contains 7 German special characters: "� � � � � � �" in Arial.
This line contains 7 German special characters: "� � � � � � �" in Courier New.
This line contains 7 German special characters with normal letters between: "�a�o�u�A�O�U�S".
RichMemo_Umlaute.txt (295 bytes)   

Dmitry Boyarintsev

2020-01-19 16:50

developer   ~0120548

keep in mind, if you're using RTF property editor, then you also need to rebuild IDE itself (after richmemo svn update).

In order to avoid rebuilding IDE, i'd recommend to use either one of the samples or your own custom project.
umlaute.png (22,311 bytes)   
umlaute.png (22,311 bytes)   

Hartmut

2020-01-19 17:17

reporter   ~0120551

I'm not sure if I understand you correctly.
First I uninstalled RichMemo r7297 via "Lazarus menu Package / Install/Uninstall packages" and rebuild the IDE (not sure if that is necessary).
After that I unzipped RichMemo r7299 and installed it via "Lazarus menu Package / Open Package File (.lpk)" and rebuild the IDE.
Is something wrong with this?
You attached a file "umlaute.png". What shall it show to me?

Dmitry Boyarintsev

2020-01-19 17:55

developer   ~0120556

your steps are correct.
if you're using .zip file, could you please check "revision.txt" file in richmemo directory?
what's the number shown there?

the screenshot is intended to demonstrate that the problem is solved.

Hartmut

2020-01-19 19:08

reporter   ~0120558

I checked the ZIP-file, but unfortunately there is no "revision.txt" included. I created a screenshot (files_of_r7299.png) for you: on the left side you see the original contents of file "lazarus-ccr-svn-r7299-components-richmemo.zip". On the right side you see the unpacked working folder, which I installed in Lazarus 2.0.6 with FPC 3.0.4. The newest file is marked red. All files in the subfolders are older.

You wrote "the screenshot (umlaute.png) is intended to demonstrate that the problem is solved".
But it shows the issues that I described:
 - in the 3rd line the Blanks between the German special characters and the ending <"> are missing
 - in the 4th line the letters between the German special characters are missing
To reproduce the bug, you must:
 - create a new RTF-file with RichMemo r7299
 - enter the text from "RichMemo_Umlaute.txt" (attached 2020-01-19 12:01)
 - format it with Arial 11 respectively Courier New 11
 - open the resulting file with Wordpad on Windows or on Linux with LibreOffice or with "wine wordpad"
 - you will see the 2 issues I described
If not, please send me a screenhot and tell me, which of those 3 programs you used including it's version# and your OS with version#.
Thanks Dmitry for your help.

Hartmut

2020-01-19 19:10

reporter  

files_of_r7299.png (42,856 bytes)   
files_of_r7299.png (42,856 bytes)   

Dmitry Boyarintsev

2020-01-20 00:16

developer   ~0120566

please test r7305 and close if ok

i actually misread the bug report. I didn't realize the second part is about SAVING rather than LOADING. (until your last post)

Hartmut

2020-01-22 13:12

reporter   ~0120670

I tested with r7313. Both problem now are fixed perfectly. Thanks a lot.

Issue History

Date Modified Username Field Change
2020-01-14 18:58 Hartmut New Issue
2020-01-14 18:58 Hartmut File Added: Wordpad.rtf
2020-01-14 18:58 Hartmut File Added: RichMemo_Editor.png
2020-01-14 18:58 Hartmut File Added: Wordpad.png
2020-01-14 18:58 Hartmut File Added: RichMemo_Umlaute.rtf
2020-01-14 18:58 Hartmut File Added: RichMemo_Umlaute.png
2020-01-14 18:58 Hartmut File Added: RichMemo_Umlaute_Wordpad.png
2020-01-17 17:09 Dmitry Boyarintsev Assigned To => Dmitry Boyarintsev
2020-01-17 17:09 Dmitry Boyarintsev Status new => resolved
2020-01-17 17:09 Dmitry Boyarintsev Resolution open => fixed
2020-01-17 17:09 Dmitry Boyarintsev Widgetset GTK 2 => GTK 2
2020-01-17 17:09 Dmitry Boyarintsev Note Added: 0120498
2020-01-18 16:35 Hartmut Status resolved => feedback
2020-01-18 16:35 Hartmut Resolution fixed => reopened
2020-01-18 16:35 Hartmut Note Added: 0120515
2020-01-18 16:38 Hartmut File Added: RichMemo_Umlaute2.rtf
2020-01-18 16:38 Hartmut File Added: RichMemo_Umlaute2.png
2020-01-18 16:38 Hartmut File Added: RichMemo_Umlaute2_Wordpad.png
2020-01-18 16:38 Hartmut File Added: RichMemo_Umlaute2_Wine_Wordpad.png
2020-01-18 16:50 Hartmut Note Added: 0120519
2020-01-18 16:50 Hartmut Status feedback => assigned
2020-01-18 20:52 Dmitry Boyarintsev Status assigned => resolved
2020-01-18 20:52 Dmitry Boyarintsev Widgetset GTK 2 => GTK 2
2020-01-18 20:52 Dmitry Boyarintsev Note Added: 0120522
2020-01-19 12:00 Hartmut Status resolved => feedback
2020-01-19 12:00 Hartmut Note Added: 0120542
2020-01-19 12:01 Hartmut File Added: RichMemo_Umlaute3.rtf
2020-01-19 12:01 Hartmut File Added: RichMemo_Umlaute3.png
2020-01-19 12:01 Hartmut File Added: RichMemo_Umlaute3_Wordpad.png
2020-01-19 12:01 Hartmut File Added: RichMemo_Umlaute3_LibreOffice.png
2020-01-19 12:01 Hartmut File Added: RichMemo_Umlaute.txt
2020-01-19 16:50 Dmitry Boyarintsev File Added: umlaute.png
2020-01-19 16:50 Dmitry Boyarintsev Note Added: 0120548
2020-01-19 17:11 Dmitry Boyarintsev Status feedback => resolved
2020-01-19 17:11 Dmitry Boyarintsev Widgetset GTK 2 => GTK 2
2020-01-19 17:17 Hartmut Status resolved => feedback
2020-01-19 17:17 Hartmut Note Added: 0120551
2020-01-19 17:55 Dmitry Boyarintsev Note Added: 0120556
2020-01-19 17:55 Dmitry Boyarintsev Status feedback => resolved
2020-01-19 17:55 Dmitry Boyarintsev Widgetset GTK 2 => GTK 2
2020-01-19 19:08 Hartmut Status resolved => feedback
2020-01-19 19:08 Hartmut Note Added: 0120558
2020-01-19 19:10 Hartmut File Added: files_of_r7299.png
2020-01-20 00:16 Dmitry Boyarintsev Note Added: 0120566
2020-01-20 00:16 Dmitry Boyarintsev Status feedback => resolved
2020-01-20 00:16 Dmitry Boyarintsev Widgetset GTK 2 => GTK 2
2020-01-22 13:12 Hartmut Status resolved => closed
2020-01-22 13:12 Hartmut Note Added: 0120670