View Issue Details

IDProjectCategoryView StatusLast Update
0036581FPCfpReportpublic2020-01-20 07:57
ReporterPascal Riekenberg Assigned ToMichael Van Canneyt  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Platformi386OSWindows 10 x64 
Product Version3.3.1 
Fixed in Version3.3.1 
Summary0036581: [Patch] Bugfixing fpreport demos and new test for rendered demos
Description- fixed Demos
- added TestDemos (compares rendered reports)
Additional InformationDejavuSans and Ubuntu-Fonst are missing in demos\fonts (needed by FFTDemo)

https://assets.ubuntu.com/v1/0cef8205-ubuntu-font-family-0.83.zip
https://www.fontsquirrel.com/fonts/download/dejavu-sans
TagsNo tags attached.
Fixed in Revision43973
FPCOldBugId
FPCTarget3.2.0
Attached Files

Activities

Pascal Riekenberg

2020-01-14 20:00

reporter  

fpreport_tests.zip (867,797 bytes)

Pascal Riekenberg

2020-01-15 10:22

reporter   ~0120461

Sorry, some files missing in first patch.
fpreport_tests.2.zip (1,088,350 bytes)

Pascal Riekenberg

2020-01-15 11:21

reporter   ~0120462

Some addition changes/fixes.
fpreport_tests.3.zip (1,088,351 bytes)

Pascal Riekenberg

2020-01-17 10:10

reporter   ~0120491

Added an second run to each report and found a few bugs which i fixed also.
fpreport_tests.4.zip (1,087,226 bytes)

Michael Van Canneyt

2020-01-18 17:42

administrator   ~0120520

Last edited: 2020-01-18 17:43

View 2 revisions

Applied, amended somewhat.

I didn't commit the JSON files. They're platform and localization dependent, as noted in the README:

---
The reason these files are not stored in SVN is that they are dependent on
the platform:
a) The reports contain newlines.
   Depending on the platform they will be saved as \r \r\n or \n.
b) There can and will be localization issues.
--

And I made the running of these demos optional, under a define. USEDEMOS (all explained in the README.md)

And of course: Thank you for the patch !

Issue History

Date Modified Username Field Change
2020-01-14 20:00 Pascal Riekenberg New Issue
2020-01-14 20:00 Pascal Riekenberg Status new => assigned
2020-01-14 20:00 Pascal Riekenberg Assigned To => Michael Van Canneyt
2020-01-14 20:00 Pascal Riekenberg File Added: fpreport_tests.zip
2020-01-15 10:22 Pascal Riekenberg File Added: fpreport_tests.2.zip
2020-01-15 10:22 Pascal Riekenberg Note Added: 0120461
2020-01-15 11:21 Pascal Riekenberg File Added: fpreport_tests.3.zip
2020-01-15 11:21 Pascal Riekenberg Note Added: 0120462
2020-01-17 10:10 Pascal Riekenberg File Added: fpreport_tests.4.zip
2020-01-17 10:10 Pascal Riekenberg Note Added: 0120491
2020-01-18 17:42 Michael Van Canneyt Status assigned => resolved
2020-01-18 17:42 Michael Van Canneyt Resolution open => fixed
2020-01-18 17:42 Michael Van Canneyt Fixed in Version => 3.3.1
2020-01-18 17:42 Michael Van Canneyt Fixed in Revision => 43973
2020-01-18 17:42 Michael Van Canneyt FPCTarget => 3.2.0
2020-01-18 17:42 Michael Van Canneyt Note Added: 0120520
2020-01-18 17:43 Michael Van Canneyt Note Edited: 0120520 View Revisions
2020-01-20 07:57 Pascal Riekenberg Status resolved => closed