View Issue Details

IDProjectCategoryView StatusLast Update
0036590LazarusWidgetsetpublic2020-01-25 14:11
ReporterCudaText man Assigned ToZeljan Rikalo  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionreopened 
PlatformUbuntu 19.10 x64 
Product Version2.1 (SVN) 
Summary0036590: Qt: TPanel.Color is not rendered
Descriptiondemo attached. in it, change Color of panel via right colorbox, and see it's not applied.
but it's used for bevel - a) set BevelWidth>1, b) set BevelOuter=Space, BevelInner=Lowered.
TagsNo tags attached.
Fixed in Revision62582,62587
LazTarget-
WidgetsetQT, QT5
Attached Files

Activities

CudaText man

2020-01-15 23:18

reporter  

tst-panel.zip (3,915 bytes)

CudaText man

2020-01-15 23:20

reporter   ~0120469

Last edited: 2020-01-16 13:27

View 2 revisions

NOTE!
Color is not rendered when BevelWidth>1.

It's for Qt/Qt5.

Zeljan Rikalo

2020-01-24 09:53

developer   ~0120702

Please test and close if ok.

CudaText man

2020-01-24 10:31

reporter  

qt-line-unneeded.png (31,651 bytes)   
qt-line-unneeded.png (31,651 bytes)   

CudaText man

2020-01-24 10:31

reporter   ~0120704

Last edited: 2020-01-24 10:32

View 2 revisions

fixed.
another issue.
qt/qt5 paint unneeded 1 px frame with bevels, so bevel has redundant line.
to see it-- in demo, set bevelInner+bevelOuter to Raised or Lowered, and set bevelWidth=5. screenshot.
gray line is painted over white area, and lite gray line is over dark area.

Zeljan Rikalo

2020-01-24 12:35

developer   ~0120705

Cannot fix that, Qt paints that extra line.

Zeljan Rikalo

2020-01-24 16:57

developer   ~0120712

It's about lcl drawing, not Qt

Zeljan Rikalo

2020-01-24 16:59

developer   ~0120713

Please test (qt4 only - qt widgetset atm) with attached patch.
qt4drawframefix.diff (510 bytes)   
Index: lcl/interfaces/qt/qtobjects.pas
===================================================================
--- lcl/interfaces/qt/qtobjects.pas	(revision 62583)
+++ lcl/interfaces/qt/qtobjects.pas	(working copy)
@@ -2526,7 +2526,7 @@
       Palette := QWidget_palette(Parent);
   end;
   // since q_DrawWinPanel doesnot supports lineWidth we should do it ourself
-  for i := 1 to lineWidth - 2 do
+  for i := 1 to lineWidth - 1 do
   begin
     q_DrawWinPanel(Widget, x, y, w, h, Palette, Sunken);
     inc(x);
qt4drawframefix.diff (510 bytes)   

CudaText man

2020-01-24 19:00

reporter   ~0120718

atfer this fix, panel's back color is not rendered (with bevelWidth>1).

Zeljan Rikalo

2020-01-25 10:51

developer   ~0120731

It's rendered fine here, are you sure that you're using trunk lazarus ?

CudaText man

2020-01-25 11:19

reporter   ~0120732

Last edited: 2020-01-25 11:20

View 2 revisions

it's ok, sorry - now i reset SVN and it's ok.

Zeljan Rikalo

2020-01-25 14:11

developer   ~0120733

Please test and close if ok.

Issue History

Date Modified Username Field Change
2020-01-15 23:18 CudaText man New Issue
2020-01-15 23:18 CudaText man File Added: tst-panel.zip
2020-01-15 23:20 CudaText man Note Added: 0120469
2020-01-16 08:26 Zeljan Rikalo Assigned To => Zeljan Rikalo
2020-01-16 08:26 Zeljan Rikalo Status new => assigned
2020-01-16 13:27 CudaText man Note Edited: 0120469 View Revisions
2020-01-24 09:53 Zeljan Rikalo Status assigned => resolved
2020-01-24 09:53 Zeljan Rikalo Resolution open => fixed
2020-01-24 09:53 Zeljan Rikalo Fixed in Revision => 62582
2020-01-24 09:53 Zeljan Rikalo LazTarget => -
2020-01-24 09:53 Zeljan Rikalo Widgetset QT => QT, QT5
2020-01-24 09:53 Zeljan Rikalo Note Added: 0120702
2020-01-24 10:31 CudaText man File Added: qt-line-unneeded.png
2020-01-24 10:31 CudaText man Note Added: 0120704
2020-01-24 10:32 CudaText man Status resolved => assigned
2020-01-24 10:32 CudaText man Resolution fixed => reopened
2020-01-24 10:32 CudaText man Note Edited: 0120704 View Revisions
2020-01-24 12:35 Zeljan Rikalo Status assigned => resolved
2020-01-24 12:35 Zeljan Rikalo Resolution reopened => not fixable
2020-01-24 12:35 Zeljan Rikalo Widgetset QT, QT5 => QT, QT5
2020-01-24 12:35 Zeljan Rikalo Note Added: 0120705
2020-01-24 16:57 Zeljan Rikalo Status resolved => assigned
2020-01-24 16:57 Zeljan Rikalo Resolution not fixable => reopened
2020-01-24 16:57 Zeljan Rikalo Note Added: 0120712
2020-01-24 16:59 Zeljan Rikalo File Added: qt4drawframefix.diff
2020-01-24 16:59 Zeljan Rikalo Note Added: 0120713
2020-01-24 19:00 CudaText man Note Added: 0120718
2020-01-25 10:51 Zeljan Rikalo Note Added: 0120731
2020-01-25 11:19 CudaText man Note Added: 0120732
2020-01-25 11:20 CudaText man Note Edited: 0120732 View Revisions
2020-01-25 14:11 Zeljan Rikalo Status assigned => resolved
2020-01-25 14:11 Zeljan Rikalo Fixed in Revision 62582 => 62582,62587
2020-01-25 14:11 Zeljan Rikalo Widgetset QT, QT5 => QT, QT5
2020-01-25 14:11 Zeljan Rikalo Note Added: 0120733