View Issue Details

IDProjectCategoryView StatusLast Update
0036593FPCCompilerpublic2020-01-23 01:57
ReporterAnton Kavalenka Assigned To 
PriorityimmediateSeverityblockReproducibilityalways
Status closedResolutionfixed 
Platformi386OSMicrosoft Windows 
Product Version3.3.1 
Fixed in Version3.3.1 
Summary0036593: compiler: svn rev 43949 broke building i386-win32
DescriptionC:/fpc-3.0.0/bin/i386-win32/ppc386.exe -Ur -Xs -O2 -n -Fi../inc -Fi../i386 -Fi../win -FE. -FUC:/projects/fpc/rtl/units/i386-win32 -di386 -dRELEASE -Us -Sg system.pp -Fi../win
cpummprocs.inc(1,40) Error: Identifier not found "__m128"
....
cpummprocs.inc(29,43) Error: Identifier not found "__m128"
cpummprocs.inc(29,43) Fatal: There were 50 errors compiling module, stopping
Fatal: Compilation aborted
TagsNo tags attached.
Fixed in Revision43967
FPCOldBugId
FPCTarget-
Attached Files

Relationships

related to 0036601 closedSven Barth Can't build Lazarus trunk under i386-linux due to 'Fatal: (6047) Cannot find system type "__m64" ' error. 

Activities

Anton Kavalenka

2020-01-16 14:22

reporter   ~0120478

fpc 3.3.1 also can not build the target

J. Gareth Moreton

2020-01-16 15:40

developer   ~0120479

This looks like the assembler intrinsics at long last! How is __m128 declared though? I would dare ask if it should be TM128 instead so it's more Pascal-like... granted, it depends on where it's being declared.

Anton Kavalenka

2020-01-16 17:01

reporter   ~0120480

compiler/psystem.pas:480

        addtype('__m128', x86_m128type);

J. Gareth Moreton

2020-01-16 23:05

developer   ~0120487

Confirmed for i386-win32 (x86_64-win64 works).

Anton Kavalenka

2020-01-18 10:04

reporter   ~0120504

crosscompilation x86_64-linux to i386-win32 works

Cyrax

2020-01-18 11:47

reporter   ~0120507

Bootstrapping with FPC 3.0.4 i386-linux release version fails.

make rtl
make[5]: Entering directory '/mnt/shares/ohjelmointi2/fpc/source/git_source/compiler'
make -C /mnt/shares/ohjelmointi2/fpc/source/git_source/rtl 'OPT=-gw2 -godwarfsets -godwarfmethodclassprefix -gl -O- -Xs- -Si- -vbq -Sew- -XX- -CX- -dEXTDEBUG -vh- -vn- -vw- -dDEBUG_NODE_XML -Cit -gt -gv -Cg  -Fl/lib -Fl/usr/lib -Fl/usr/lib/gcc/i686-pc-linux-gnu/9.2.0 -dTEST_WIN32_SEH  ' all
make[6]: Entering directory '/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl'
make -C linux all
make[7]: Entering directory '/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/linux'
/usr/bin/mkdir -p /mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/units/i386-linux
fpc -Ur -XX -CX -Ur -Xs -O2 -n -Fi../inc -Fi../i386 -Fi../unix -Fii386 -FE. -FU/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/units/i386-linux -gw2 -godwarfsets -godwarfmethodclassprefix -gl -O- -Xs- -Si- -vbq -Sew- -XX- -CX- -dEXTDEBUG -vh- -vn- -vw- -dDEBUG_NODE_XML -Cit -gt -gv -Cg -Fl/lib -Fl/usr/lib -Fl/usr/lib/gcc/i686-pc-linux-gnu/9.2.0 -dTEST_WIN32_SEH -di386 -dRELEASE  -Us -Sg system.pp
Compiling Release Version
Free Pascal Compiler version 3.0.4-r37149 [2018/02/11] for i386
Copyright (c) 1993-2017 by Florian Klaempfl and others
(1002) Target OS: Linux for i386
(3104) Compiling system.pp
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(1,40) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(2,41) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(3,41) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(4,44) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(5,45) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(6,45) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(7,30) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(8,39) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(9,31) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(9,53) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(10,31) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(10,53) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(11,36) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(11,45) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(12,36) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(12,45) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(13,34) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(13,43) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(14,34) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(14,43) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(15,34) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(15,43) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(16,34) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(16,43) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(17,34) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(17,43) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(18,35) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(18,44) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(19,34) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(19,43) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(20,34) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(20,43) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(21,36) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(21,45) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(22,34) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(22,43) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(23,34) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(23,43) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(24,34) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(24,43) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(25,34) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(25,43) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(26,34) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(26,43) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(27,35) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(27,44) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(28,34) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(28,43) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(29,34) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(29,43) Error: (5000) Identifier not found "__m128"
/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/i386/cpummprocs.inc(29,43) Fatal: (10026) There were 50 errors compiling module, stopping
Fatal: (1018) Compilation aborted
Error: /mnt/shares/ohjelmointi2/fpc/i386/release/3.0.4/binary/release/bin/i386-linux/ppc386 returned an error exitcode
make[7]: *** [Makefile:3957: system.ppu] Error 1
make[7]: Leaving directory '/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl/linux'
make[6]: *** [Makefile:2071: linux_all] Error 2
make[6]: Leaving directory '/mnt/shares/ohjelmointi2/fpc/source/git_source/rtl'
make[5]: *** [Makefile:4691: rtl] Error 2
make[5]: Leaving directory '/mnt/shares/ohjelmointi2/fpc/source/git_source/compiler'
make[4]: *** [Makefile:4533: next] Error 2
make[4]: Leaving directory '/mnt/shares/ohjelmointi2/fpc/source/git_source/compiler'
make[3]: *** [Makefile:4539: ppc1] Error 2
make[3]: Leaving directory '/mnt/shares/ohjelmointi2/fpc/source/git_source/compiler'
make[2]: *** [Makefile:4555: cycle] Error 2
make[2]: Leaving directory '/mnt/shares/ohjelmointi2/fpc/source/git_source/compiler'
make[1]: *** [Makefile:2857: compiler_cycle] Error 2
make[1]: Leaving directory '/mnt/shares/ohjelmointi2/fpc/source/git_source'
make: *** [Makefile:2889: build-stamp.i386-linux] Error 2

Sven Barth

2020-01-18 12:23

manager   ~0120509

Please test and close if okay.

J. Gareth Moreton

2020-01-23 01:57

developer   ~0120681

This particular issue seems to be resolved.

Issue History

Date Modified Username Field Change
2020-01-16 14:19 Anton Kavalenka New Issue
2020-01-16 14:22 Anton Kavalenka Note Added: 0120478
2020-01-16 15:40 J. Gareth Moreton Note Added: 0120479
2020-01-16 17:01 Anton Kavalenka Note Added: 0120480
2020-01-16 23:05 J. Gareth Moreton Status new => confirmed
2020-01-16 23:05 J. Gareth Moreton FPCTarget => -
2020-01-16 23:05 J. Gareth Moreton Note Added: 0120487
2020-01-16 23:06 J. Gareth Moreton Priority normal => immediate
2020-01-16 23:06 J. Gareth Moreton Severity minor => block
2020-01-16 23:06 J. Gareth Moreton OS => Microsoft Windows
2020-01-16 23:06 J. Gareth Moreton OS Version => 10 Professional
2020-01-16 23:06 J. Gareth Moreton Platform => i386
2020-01-16 23:06 J. Gareth Moreton Build => r43960
2020-01-18 10:04 Anton Kavalenka Note Added: 0120504
2020-01-18 11:47 Cyrax Note Added: 0120507
2020-01-18 12:23 Sven Barth Assigned To => Sven Barth
2020-01-18 12:23 Sven Barth Status confirmed => resolved
2020-01-18 12:23 Sven Barth Resolution open => fixed
2020-01-18 12:23 Sven Barth Fixed in Version => 3.3.1
2020-01-18 12:23 Sven Barth Fixed in Revision => 43967
2020-01-18 12:23 Sven Barth Note Added: 0120509
2020-01-19 03:37 J. Gareth Moreton Relationship added related to 0036601
2020-01-23 01:57 J. Gareth Moreton Assigned To Sven Barth =>
2020-01-23 01:57 J. Gareth Moreton Status resolved => closed
2020-01-23 01:57 J. Gareth Moreton Note Added: 0120681