View Issue Details

IDProjectCategoryView StatusLast Update
0036605LazarusPackagespublic2020-02-16 21:52
ReporterStephano Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Summary0036605: Error building IDE with sparta_dockedformeditor package
DescriptionUpon building the IDE:
sparta_mainide.pas(1036,67) Error: Internal error 200510032
LPageCtrl := SourceEditorWindows[LastActiveSourceEditorWindow].FPageCtrlList[LastActiveSourceEditor]

Lazarus SVN rev 62571 / FPC 3.2.0
Ubuntu 16.04 64 bit
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetGTK 2
Attached Files

Relationships

related to 0034899 resolvedJuha Manninen Packages Docked form editor does not work 
related to 0035877 closedJonas Maebe FPC Trunk compiler fails with 200510032 

Activities

Stephano

2020-01-19 13:23

developer   ~0120544

The comment https://bugs.freepascal.org/view.php?id=34899#c119859 describes the same issue

Stephano

2020-01-19 21:00

developer   ~0120559

The IDE builds fine with FPC 3.3.1 (rev 43977).
It is highly probable that commit 42987 (FPC 3.3.1) solved the internal error 200510032 issue (https://bugs.freepascal.org/view.php?id=35877). If so, it ought to be merged into FPC 3.2.0

Juha Manninen

2020-02-16 21:52

developer   ~0121133

Resolving as "no change required" because this is not a Lazarus bug.
Stephano, please contact FPC mailing list to make sure that r42987 gets backported to FPC 3.2.

Issue History

Date Modified Username Field Change
2020-01-19 13:22 Stephano New Issue
2020-01-19 13:23 Stephano Note Added: 0120544
2020-01-19 21:00 Stephano Note Added: 0120559
2020-01-20 07:45 Juha Manninen Relationship added related to 0034899
2020-01-20 07:46 Juha Manninen Relationship added related to 0035877
2020-02-16 21:52 Juha Manninen Assigned To => Juha Manninen
2020-02-16 21:52 Juha Manninen Status new => resolved
2020-02-16 21:52 Juha Manninen Resolution open => no change required
2020-02-16 21:52 Juha Manninen LazTarget => -
2020-02-16 21:52 Juha Manninen Widgetset GTK 2 => GTK 2
2020-02-16 21:52 Juha Manninen Note Added: 0121133