View Issue Details

IDProjectCategoryView StatusLast Update
0036611FPCRTLpublic2020-01-21 00:11
ReporterKarl-Michael SchindlerAssigned ToFlorian 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformdarwinOSMac OS XOS Version10.5, 10.6
Product Version3.3.1Product Buildsvn commit 43997 
Target VersionFixed in Version3.3.1 
Summary0036611: svn commit 43997 breaks building the rtl for avr-embeded
Descriptionbuilding the crosscompiler breaks with:

...
/BlaBla/FreePascal/compiler/ppcrossavr -Cpavr6 -Ur -Tembedded -Pavr -XPavr-embedded- -Xr -Ur -Xs -O2 -n -Fi../inc -Fi../avr -FE. -FU/BlaBla/FreePascal/rtl/units/avr-embedded -ap -v0 -Fl/Library/Developer/CommandLineTools/SDKs/MacOSX.sdk/usr/lib -davr -dRELEASE -XPavr- -Us -Sg system.pp @system.cfg
int64.inc(564,7) Fatal: Internal error 200309041
Fatal: Compilation aborted
...
Steps To Reproducesvn up -r 43997
make clean all OPT="-ap -v0 -Fl/Library/Developer/CommandLineTools/SDKs/MacOSX.sdk/usr/lib" CROSSOPT="-XPavr-" CPU_TARGET=avr OS_TARGET=embedded SUBARCH=avr6
Additional InformationIt affects all subarchs (25, 35, 4, 5, 51, 6). System is macOS 10.14, Xcode 11.3.1, fpc bootstrap compiler is 3.0.4 from macports.
TagsNo tags attached.
Fixed in Revision44005
FPCOldBugId
FPCTarget-
Attached Files

Activities

Christo Crause

2020-01-20 19:09

reporter   ~0120571

The problem is a space between the { and define on line 33 in rtl/embedded/system.pp:
{ $define EXCLUDE_COMPLEX_PROCS}

This leads to the inclusion of procedures with parameter lists exceeding number of available registers.

The space should be deleted so that the define is active.

Florian did fix a bug in the register allocator, but it seems there is still a problem when there is high register demand.

Karl-Michael Schindler

2020-01-21 00:11

reporter   ~0120577

Fix confirmed. Thanks.

Issue History

Date Modified Username Field Change
2020-01-20 18:01 Karl-Michael Schindler New Issue
2020-01-20 19:09 Christo Crause Note Added: 0120571
2020-01-20 22:15 Florian Assigned To => Florian
2020-01-20 22:15 Florian Status new => resolved
2020-01-20 22:15 Florian Resolution open => fixed
2020-01-20 22:15 Florian Fixed in Version => 3.3.1
2020-01-20 22:15 Florian Fixed in Revision => 44005
2020-01-20 22:15 Florian FPCTarget => -
2020-01-21 00:11 Karl-Michael Schindler Status resolved => closed
2020-01-21 00:11 Karl-Michael Schindler Note Added: 0120577