View Issue Details

IDProjectCategoryView StatusLast Update
0036612LazarusIDEpublic2020-01-21 18:09
ReporterNur Cholif MurtadhoAssigned ToBart Broersma 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
PlatformWindowsOSWindowsOS Version10
Product Version2.1 (SVN)Product Build 
Target VersionFixed in Version 
Summary0036612: Codetool parses "{$IF ident > n}" wrong / Lazarus editor grayed out wrong section of const conditional compilation
DescriptionIt's grayed out the wrong section. So, I can't work with that section. Missing identifier, etc. But it compile just fine.
I need this because some library using hard coded version in its source.

Example:
...
const
  x=3;
begin
  {$if x>5}
  writeln('more than 5');
  {$else}
  writeln('less than 5');
  {$endif}
end.
Tagscodetools
Fixed in Revision0030109
LazTarget-
Widgetset
Attached Files

Relationships

duplicate of 0030109 confirmed IDE editor: {$if} doesn't evaluate constants 
related to 0034767 assignedMattias Gaertner Wrong calculation {$ifopt o-} state in TLinkScanner.IfOptDirective 
related to 0030214 assignedMattias Gaertner IFDEF + numeric identifier is always TRUE in IDE 
has duplicate 0034649 resolvedBart Broersma Source Code Editor shows inverted interpretation of $if statements 

Activities

Nur Cholif Murtadho

2020-01-21 01:50

reporter   ~0120578

It seems the issue also exist in stable Lazarus 2.0.6

Martin Friebe

2020-01-21 05:15

manager   ~0120580

Updated subject

Bart Broersma

2020-01-21 18:09

developer   ~0120662

Please search the bugtracker before posting an issue.

Issue History

Date Modified Username Field Change
2020-01-20 20:20 Nur Cholif Murtadho New Issue
2020-01-20 21:11 Cyrax Tag Attached: codetools
2020-01-21 01:50 Nur Cholif Murtadho Note Added: 0120578
2020-01-21 05:15 Martin Friebe Summary Lazarus editor grayed out wrong section of const conditional compilation => Codetool parses "{$IF ident > n}" wrong / Lazarus editor grayed out wrong section of const conditional compilation
2020-01-21 05:15 Martin Friebe LazTarget => -
2020-01-21 05:15 Martin Friebe Note Added: 0120580
2020-01-21 05:28 Martin Friebe Relationship added duplicate of 0030109
2020-01-21 05:29 Martin Friebe Relationship added has duplicate 0034649
2020-01-21 05:31 Martin Friebe Relationship added related to 0034767
2020-01-21 05:32 Martin Friebe Relationship added related to 0030214
2020-01-21 18:09 Bart Broersma Assigned To => Bart Broersma
2020-01-21 18:09 Bart Broersma Status new => resolved
2020-01-21 18:09 Bart Broersma Resolution open => duplicate
2020-01-21 18:09 Bart Broersma Fixed in Revision => 0030109
2020-01-21 18:09 Bart Broersma Note Added: 0120662