View Issue Details

IDProjectCategoryView StatusLast Update
0036615LazarusIDEpublic2020-06-06 03:39
ReporterJem Assigned ToMartin Friebe  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version2.0.6 
Summary0036615: Ide does not correctly track lines in code while stepping through code during debugging session
DescriptionWhen debugging an app in the IDE, the highlight line is 1 or 2 lines off while stepping through the source code. it is annoying, but it doesn't seem to affect the process. It also seems to get worse during long sessions of debugging.
Steps To ReproduceOn my system it happens almost always. there are times that it does not, but as a rule it is reproducible on any debug session. It does not seem to help if I shut down lazarus and re-open it.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

Martin Friebe

2020-01-21 21:09

manager   ~0120664

Does this happen in
- all units
- some units

Did you do any editing (during debugging) to the lines of a unit in which that happens?

Note: Editing is allowed and should work, but:
- Once the debugger is running and you see the blue dots on the left side of the editor, then you are allowed to edit code. That should work
- If the IDE is compiling, or the debugger is starting up (before blue dots are shown) you should not edit the code. The IDE does not track this. (But it should only affect the very next debug session. New compile, new game)

Given, that you seem to experience it with lots of diff code, it seems unlikely but https://bugs.freepascal.org/view.php?id=32091

-------------------------------
I assume that is the standard out of the box debug config? (No changes to Tools > option > debugger....)

Do you run a 64 or 32 bit IDE?
Which version of Windows?

In case of a 32bit IDE (and/or 32bit compiled apps) can you test Project > Project Options > Debugging : Set "debug info type" to "dwarf 2 with sets".
(You can try on 64 bit too, but it is unlikely to matter on 64 bit)


Can you try gdb 8.2 ?
64 bit: https://sourceforge.net/projects/lazarus/files/Lazarus%20Windows%2064%20bits/Alternative%20GDB/
32 bit: https://sourceforge.net/projects/lazarus/files/Lazarus%20Windows%2032%20bits/Alternative%20GDB/

-------
If you have breakpoints, do they stop on the line they are set?

Are the blue dots in the gutter in sync with the code, or not?
I.e., Are there blue dots where the source has an empty line?

If it happens, try a "Build" instead of compile. (or even better "clean and build")

Martin Friebe

2020-06-06 03:39

manager   ~0123247

Unable to reproduce.

If you have further feedback, which with the issue may be reproduced, then please re-open.

Issue History

Date Modified Username Field Change
2020-01-21 18:42 Jem New Issue
2020-01-21 21:09 Martin Friebe Assigned To => Martin Friebe
2020-01-21 21:09 Martin Friebe Status new => feedback
2020-01-21 21:09 Martin Friebe LazTarget => -
2020-01-21 21:09 Martin Friebe Note Added: 0120664
2020-06-06 03:39 Martin Friebe Status feedback => resolved
2020-06-06 03:39 Martin Friebe Resolution open => unable to reproduce
2020-06-06 03:39 Martin Friebe Widgetset Win32/Win64 => Win32/Win64
2020-06-06 03:39 Martin Friebe Note Added: 0123247