View Issue Details

IDProjectCategoryView StatusLast Update
0036621LazarusCompilerpublic2020-01-25 07:24
Reporterhan Assigned ToDmitry Boyarintsev  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
OSmacOS 
Product Version2.0.6 
Summary0036621: an OnDblClick event is generated by single click on Tedit for macOS only.
DescriptionMy application works fine in Linux and Windows. However in macOS for a Tedit the OnDblClick event is generated by a single click on Tedit. I have upgraded from Lazarus 2.0.0 to 2.0.6. This didn't help.

Han
Steps To ReproduceUse a Tedit in macOS, 64 bit Cocoa.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetCocoa
Attached Files

Activities

Dmitry Boyarintsev

2020-01-25 07:24

developer   ~0120726

the issue is fixed in trunk (and fixes branch)

Issue History

Date Modified Username Field Change
2020-01-22 23:54 han New Issue
2020-01-25 07:24 Dmitry Boyarintsev Assigned To => Dmitry Boyarintsev
2020-01-25 07:24 Dmitry Boyarintsev Status new => resolved
2020-01-25 07:24 Dmitry Boyarintsev Resolution open => fixed
2020-01-25 07:24 Dmitry Boyarintsev LazTarget => -
2020-01-25 07:24 Dmitry Boyarintsev Widgetset Cocoa => Cocoa
2020-01-25 07:24 Dmitry Boyarintsev Note Added: 0120726