View Issue Details

IDProjectCategoryView StatusLast Update
0036625FPCCompilerpublic2020-01-24 10:34
ReporterThaddy de KoningAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
PlatformallOSallOS Versionall
Product Version3.3.1Product Build 
Target VersionFixed in Version 
Summary0036625: class constructors and initialization sections are executed even if main program is empty
Descriptionclass constructors and initialization sections are executed even if main program is empty.
This is potentially dangerous, because code can be executed without the programmers intention.
I suggest to introduce a warning for both of these cases and finalization sections too.
This is important, because library writers can hide executable code from a programmer and to many programmers it is not always obvious to actually examine the code they are using from third parties.
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Relationships

duplicate of 0036623 new Compiler always call class constructors even if classes are not used 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2020-01-24 10:27 Thaddy de Koning New Issue
2020-01-24 10:34 Michael Van Canneyt Assigned To => Michael Van Canneyt
2020-01-24 10:34 Michael Van Canneyt Status new => resolved
2020-01-24 10:34 Michael Van Canneyt Resolution open => duplicate
2020-01-24 10:34 Michael Van Canneyt FPCTarget => -
2020-01-24 10:34 Michael Van Canneyt Relationship added duplicate of 0036623