View Issue Details

IDProjectCategoryView StatusLast Update
0036641LazarusWidgetsetpublic2020-02-01 11:42
ReporterDzmitry K. Assigned ToZeljan Rikalo  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionno change required 
Product Version2.0.6 
Summary0036641: Qt5: Sigsegv on closing application if buttons with standard icons are used
DescriptionI'm using Arch Linux on x86_64. I've tried compiling my application with Qt (I've formerly used GTK+2 interface to develop it), and I've noticed that it displays a SIGSEGV error when I exit it.

I've found that the issue is with the buttons (either TBitButton's or TButtonPanel's) that have standard icons (from the OS theme). If I remove the buttons, or use buttons without icons, or use custom icons (not from OS theme), then the problem doesn't occur.

I've tested this on 2 packages:
* lazarus-qt5 package (package version 2.0.6-2; Lazarus version 0000002.0.6, 2019-12-25, FPC Version: 3.0.6, x86_64-linux-qt5),
* SVN version as compiled via AUR package lazarus-qt5-svn (Version #: 2.1.0, Date: 2020-01-31, FPC version: 3.0.4, SVN Revision: 62599, x86_64-linux-qt5)

Some other package versions:
qt5pas 2.6.r61322-1
qt5-base 5.14.1-1
Steps To Reproduce1. Create a new project
2. Place a `TBitButton` on the form
3. Set `Kind` to `bkOK`
4. Compile and run
5. Close the window

Expected result:
The program should exit

Actual result:
An error with the following text:
Project project1 raised exception class 'External: SIGSEGV'.
Additional InformationI hope I've made the bug report correctly, but if I've missed something, please tell me! Thanks
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetQT5
Attached Files

Relationships

related to 0036019 resolvedZeljan Rikalo Qt5 programs on exit terminated with Segmentation fault 

Activities

Dzmitry K.

2020-01-31 00:14

reporter   ~0120812

The full text of the error is:
Project project1 raised exception class 'External: SIGSEGV'.

At address 7FFFF673A83C

Then, Assebler window opens, showing code below the _ZN16QCoreApplication15notifyInternal2EP7QObjectP6QEvent label

Zeljan Rikalo

2020-01-31 09:07

developer   ~0120816

Added relation to 36483 since there's Qt5-5.14 also mentioned.

Zeljan Rikalo

2020-01-31 09:48

developer   ~0120818

Installed manjaro (qt-5.14.0) and I can confirm that this is bug, but don't know yet is it about Qt5 libs or our libQt5Pas, or even fpc

Zeljan Rikalo

2020-01-31 10:25

developer   ~0120819

I've just rebuilt test project with fpc fixes 3.2.0 and it works ok. (lazarus trunk, fpc-3.2.0 fixes installed via fpcupdeluxe, libQt5Pas (1.2.7) is my built on Fedora 29 64bit.

Dzmitry K.

2020-02-01 11:10

reporter   ~0120833

Hello! Thanks, it indeed doesn't occur with the newest Freepascal! (I've used AUR packages fpc-svn, lazarus-svn, lazarus-qt5-svn in Arch, everything works perfectly). Thanks!

Zeljan Rikalo

2020-02-01 11:42

developer   ~0120835

Please close.

Issue History

Date Modified Username Field Change
2020-01-31 00:11 Dzmitry K. New Issue
2020-01-31 00:14 Dzmitry K. Note Added: 0120812
2020-01-31 09:05 Zeljan Rikalo Assigned To => Zeljan Rikalo
2020-01-31 09:05 Zeljan Rikalo Status new => assigned
2020-01-31 09:07 Zeljan Rikalo Relationship added related to 0036483
2020-01-31 09:07 Zeljan Rikalo Note Added: 0120816
2020-01-31 09:48 Zeljan Rikalo Status assigned => confirmed
2020-01-31 09:48 Zeljan Rikalo LazTarget => -
2020-01-31 09:48 Zeljan Rikalo Note Added: 0120818
2020-01-31 10:25 Zeljan Rikalo Status confirmed => feedback
2020-01-31 10:25 Zeljan Rikalo Note Added: 0120819
2020-01-31 15:19 Zeljan Rikalo Relationship deleted related to 0036483
2020-01-31 15:20 Zeljan Rikalo Relationship added related to 0036019
2020-02-01 11:10 Dzmitry K. Note Added: 0120833
2020-02-01 11:10 Dzmitry K. Status feedback => assigned
2020-02-01 11:42 Zeljan Rikalo Status assigned => resolved
2020-02-01 11:42 Zeljan Rikalo Resolution open => no change required
2020-02-01 11:42 Zeljan Rikalo Widgetset QT5 => QT5
2020-02-01 11:42 Zeljan Rikalo Note Added: 0120835