View Issue Details

IDProjectCategoryView StatusLast Update
0036648FPCDocumentationpublic2020-02-04 12:58
Reportersuve Assigned ToMichael Van Canneyt  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Summary0036648: [PATCH] Fix unescaped $ in Latex in errore.msg
DescriptionRevision 44035 adds some extra text to compiler/msg/errore.msg. This text causes building the docs by "make pdf" to fail due to an unescaped "$" character.
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Activities

suve

2020-02-01 15:31

reporter  

fpc--fix-errore-latex.patch (750 bytes)   
--- fpc-r44069/compiler/msg/errore.msg	2020-02-01 14:19:01.854314629 +0100
+++ fpc-r44069/compiler/msg/errore--patched.msg	2020-02-01 14:31:54.460662439 +0100
@@ -2038,9 +2038,9 @@
 % If a set is constructed like this: \var{s:=[9..7];]}, then an empty set is generated. As this is something normally not desired, the compiler warns about it.
 type_e_cblock_callconv=04126_E_C block reference must use CDECL or MWPASCAL calling convention.
 % When declaring a C block reference ensure that it uses either the \var{cdecl} or \var{mwpascal}
 % calling convention either by adding the corresponding function directive or by using the
-% \var{$Calling} compiler directive.
+% \var{\{\$Calling\}} compiler directive.
 % \end{description}
 #
 # Symtable
 #
fpc--fix-errore-latex.patch (750 bytes)   

Marco van de Voort

2020-02-04 09:31

manager   ~0120874

Which branch? This seems to be fixed already on 2020-01-01 in trunk?

Michael Van Canneyt

2020-02-04 12:58

administrator   ~0120881

Revision 44035 is the fixes_3_2 branch. It was already fixed.

Issue History

Date Modified Username Field Change
2020-02-01 14:53 suve New Issue
2020-02-01 14:53 suve Status new => assigned
2020-02-01 14:53 suve Assigned To => Michael Van Canneyt
2020-02-01 15:31 suve File Added: fpc--fix-errore-latex.patch
2020-02-04 09:31 Marco van de Voort Note Added: 0120874
2020-02-04 12:57 Michael Van Canneyt Status assigned => resolved
2020-02-04 12:57 Michael Van Canneyt Resolution open => fixed
2020-02-04 12:58 Michael Van Canneyt FPCTarget => -
2020-02-04 12:58 Michael Van Canneyt Note Added: 0120881