View Issue Details

IDProjectCategoryView StatusLast Update
0036657LazarusIDEpublic2020-02-16 19:48
ReporterLibaud Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
PlatformLinuxOSLinux Mint 
Product Version2.0.6 
Summary0036657: Error to recompile Lazarus 2.x with the menu on Tools
DescriptionIt is impossible to recompile Lazarus 2.x (I've tested with all stable 2.X release).

There's a message show : Fichier "/usr/share/lazarus/2.0.6/ide/projectresourcesintf.pas" non trouvé. This says that the file indicate isn't in the path !

The message on the output is "projectresourcesintf.pas(161,31) Fatal: Impossible de trouver ProjectResourcesIntf utilisé par IDEIntf - ppu=/usr/share/lazarus/2.0.6/components/ideintf/units/x86_64-linux/gtk2/projectresourcesintf.ppu incompatible - paquet IDEIntf".

I've the same error with GT3, QT5 and other parameters for compilation
Steps To ReproduceRespect the install process with the last debian package available for the 2.x release and execute build IDE on the menu Tools.
Additional InformationPackage installation provide two ppu files :
- /usr/share/lazarus/2.0.6/components/ideintf/units/x86_64-linux/nogui/projectresourcesintf.ppu
- /usr/share/lazarus/2.0.6/components/ideintf/units/x86_64-linux/gtk2/projectresourcesintf.ppu

Package installation provide one pas file :
- /usr/share/lazarus/2.0.6/components/ideintf/projectresourcesintf.pas
This doesn't compile

I've GTK 2 & 3 AND QT 4 & 5 installed on my system.
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Activities

Juha Manninen

2020-02-16 19:47

developer   ~0121129

Last edited: 2020-02-16 19:48

View 2 revisions

The release version compiles fine here on Manjaro Linux.
The incompatible ppu error is quite certainly a local problem with old leftover installations and ppu files around.
Please uninstall, remove every trace of the old installations, then install again. If you still have problems, please ask the forum.
 https://forum.lazarus.freepascal.org
There are tens of threads about installation problems in Ubuntu and Mint. Please read them.

I personally recommend you to install FPC from Mint repo, then download sources for Lazarus 2.0 fixes branch and build them with "make".
This recommendation can also be found in the forum threads.

Resolving this as "no change required".

Issue History

Date Modified Username Field Change
2020-02-04 16:30 Libaud New Issue
2020-02-16 19:47 Juha Manninen Assigned To => Juha Manninen
2020-02-16 19:47 Juha Manninen Status new => resolved
2020-02-16 19:47 Juha Manninen Resolution open => no change required
2020-02-16 19:47 Juha Manninen LazTarget => -
2020-02-16 19:47 Juha Manninen Note Added: 0121129
2020-02-16 19:48 Juha Manninen Note Edited: 0121129 View Revisions