View Issue Details

IDProjectCategoryView StatusLast Update
0036660FPCCompilerpublic2020-12-29 14:59
ReporterJ. Gareth Moreton Assigned ToJonas Maebe  
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionnot fixable 
Platformi386-win32OSMicrosoft Windows 
Product Version3.3.1 
Summary0036660: "make all" crashes on i386-win32 when OPT="-CriotR" is specified.
DescriptionWhen attempting to make the compiler under i386-win32 with all the debugging checks enabled, an access violation is triggered during the bootstrapping cycle.
Steps To Reproducecall "make clean all install OS_TARGET=win32 CPU_TARGET=i386 OPT="-CriotR" under i386-win32 - observe access violation when it attempts to compile the WPO segment of the bootstrapping cycle.
Additional InformationI'm really hoping this isn't due to one of my optimisations!

Doesn't appear to occur under x86_64-win64.
Tagsaccess violation, compiler, i386, internal error, make
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Relationships

duplicate of 0038136 resolvedYuriy Sydorov i386-win32 compiler build crashes at WPO stage under -CriotR 

Activities

Marco van de Voort

2020-07-02 21:54

manager   ~0123721

still the case with trunk and 3.2.0 as starting compiler. Exception building buildRTL with WPO

Issue History

Date Modified Username Field Change
2020-02-05 03:43 J. Gareth Moreton New Issue
2020-02-05 03:43 J. Gareth Moreton Tag Attached: compiler
2020-02-05 03:43 J. Gareth Moreton Tag Attached: i386
2020-02-05 03:43 J. Gareth Moreton Tag Attached: internal error
2020-02-05 03:43 J. Gareth Moreton Tag Attached: access violation
2020-02-05 03:43 J. Gareth Moreton Tag Attached: make
2020-02-05 03:44 J. Gareth Moreton Priority normal => high
2020-02-05 03:44 J. Gareth Moreton FPCTarget => -
2020-02-05 03:45 J. Gareth Moreton Summary "make all" crashes on i386-win32 when OPT="-CriotR" specified. => "make all" crashes on i386-win32 when OPT="-CriotR" is specified.
2020-07-02 21:54 Marco van de Voort Note Added: 0123721
2020-12-29 14:59 Jonas Maebe Assigned To => Jonas Maebe
2020-12-29 14:59 Jonas Maebe Status new => resolved
2020-12-29 14:59 Jonas Maebe Resolution open => not fixable
2020-12-29 14:59 Jonas Maebe Relationship added duplicate of 0038136