View Issue Details

IDProjectCategoryView StatusLast Update
0036742LazarusIDEpublic2020-02-28 19:16
ReporterAnthony Walter Assigned ToOndrej Pokorny  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
PlatformAllOSAll 
Product Version2.0.7 (SVN) 
Summary0036742: CodeTools does not support {$modeswitch multihelpers}
DescriptionWhen using multiple type helpers with codeswitch {$modeswitch multihelpers}, the CodeTools system does not recognize multiple type helpers. When you try to type a line of code in a unit that uses more than one type helper for a specific type, code tools acts as if your line is incorrect and stop providing code insight, parameter insight, and other help for said line. In effect it sees you line as invalid and does not work at all for that line and does not provide suggestions for multiple type helper extension methods or properties on that type.
Additional InformationI no longer see a CodeTools category so I filed with under IDE.
Tagscodetools, type helpers
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

duplicate of 0035911 closedOndrej Pokorny CodeTools lack {$modeswitch multihelpers} support 

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2020-02-28 17:51 Anthony Walter New Issue
2020-02-28 17:53 Anthony Walter Tag Attached: codetools
2020-02-28 17:53 Anthony Walter Tag Attached: type helpers
2020-02-28 19:16 Ondrej Pokorny Assigned To => Ondrej Pokorny
2020-02-28 19:16 Ondrej Pokorny Status new => resolved
2020-02-28 19:16 Ondrej Pokorny Resolution open => duplicate
2020-02-28 19:16 Ondrej Pokorny LazTarget => -
2020-02-28 19:16 Ondrej Pokorny Relationship added duplicate of 0035911