View Issue Details

IDProjectCategoryView StatusLast Update
0036748LazarusOtherpublic2020-03-07 14:43
Reporterbrahim Assigned ToBart Broersma  
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionno change required 
Product Version2.0.6 
Summary0036748: displaying margins in TMemo component
Descriptionhi @all,

Suggestion : to add margins(left,right,top,bottom) properties in the Object Inspector for TMemo component
it will be usefull than manually call it with this method

 SendMessage(Memo1.Handle, EM_SETRECT, 0, LongInt(@R));
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Activities

Bart Broersma

2020-03-04 09:51

developer   ~0121350

This can only be considered if there is a cross-platform solution to do that.
Q: Does Delphi support this?

Zeljan Rikalo

2020-03-04 09:55

developer   ~0121351

BorderSpacing.Around does not help ?

Bart Broersma

2020-03-04 10:11

developer   ~0121353

He's talking about internal margings of the memo.
Even if we implement this, the user would have to update that on each resize of the memo, since the Rect in the parameter to SendMessage defines a rectangle measured from the top (it's values for bottom and right are relative to (0,0)).

So, unless an implementation is made that handles resize, IMO such a property is pretty useless.

Bart Broersma

2020-03-07 14:43

developer   ~0121430

Please close.

Issue History

Date Modified Username Field Change
2020-03-02 03:07 brahim New Issue
2020-03-04 09:51 Bart Broersma Note Added: 0121350
2020-03-04 09:51 Bart Broersma Status new => feedback
2020-03-04 09:51 Bart Broersma LazTarget => -
2020-03-04 09:55 Zeljan Rikalo Note Added: 0121351
2020-03-04 10:07 Bart Broersma Severity minor => feature
2020-03-04 10:11 Bart Broersma Note Added: 0121353
2020-03-07 14:43 Bart Broersma Assigned To => Bart Broersma
2020-03-07 14:43 Bart Broersma Status feedback => resolved
2020-03-07 14:43 Bart Broersma Resolution open => no change required
2020-03-07 14:43 Bart Broersma Note Added: 0121430