View Issue Details

IDProjectCategoryView StatusLast Update
0036761LazarusIDEpublic2020-04-12 23:05
ReporterKurt Frank Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version2.0.6 
Summary0036761: Compile package FCL 1.0.1: missing executable "D:\Lazarus\lazarus\fpc\3.0.4\bin\x86_64-win64\fpc.exe", Errors: 1
DescriptionFresh Windows install fails to compile "Hello World" windows app the second time I start up Lazarus. Right after install it compiled no problems.

Compile package FCL 1.0.1: missing executable "D:\Lazarus\lazarus\fpc\3.0.4\bin\x86_64-win64\fpc.exe", Errors: 1
Panic: internal error: missing executable "D:\Lazarus\lazarus\fpc\3.0.4\bin\x86_64-win64\fpc.exe"

The fpc.exe file is actually at
D:\Lazarus\fpc\bin\x86_64-win64\fpc.exe

And I do not even have a D:\Lazarus\lazarus\fpc directory at all let alone the D:\Lazarus\lazarus\fpc\3.0.4 directory.
Steps To ReproduceStart Lazarus
Load Hello World project
F9
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

Kurt Frank

2020-03-06 03:13

reporter  

error.png (113,719 bytes)   
error.png (113,719 bytes)   

Akira1364

2020-03-06 19:32

reporter   ~0121418

If you click "Tools", and then "Options", the first page shown should be the "Environment" one where you can directly specify the location of your FPC executable.

Juha Manninen

2020-03-07 09:42

developer   ~0121426

Please check the "Compiler executable" setting as Akira1364 noted.
Usually "fpc" or "fpc.exe" is enough if the system PATH is set correctly.

If the compiler path really changed by itself after the first compilation, it would be a serious bug. Can somebody reproduce this? I cannot imagine any reason why it would change by itself.

Cyrax

2020-03-07 11:05

reporter   ~0121427

After installing Lazarus+FPC development suite, you probably need to log out and log in so correct environment settings are set up correctly.

Bart Broersma

2020-03-07 14:49

developer   ~0121431

@Cyrax: adjustments to the %path% by the installer are immediate, at least on WIndows AFAIK.

Juha Manninen

2020-04-01 06:06

developer   ~0121809

Kurt, did you solve this problem with the advice given?

Juha Manninen

2020-04-12 23:05

developer   ~0122099

No feedback, resolving.

Issue History

Date Modified Username Field Change
2020-03-06 03:13 Kurt Frank New Issue
2020-03-06 03:13 Kurt Frank File Added: error.png
2020-03-06 19:32 Akira1364 Note Added: 0121418
2020-03-07 09:42 Juha Manninen Note Added: 0121426
2020-03-07 11:05 Cyrax Note Added: 0121427
2020-03-07 14:49 Bart Broersma Note Added: 0121431
2020-04-01 06:06 Juha Manninen Assigned To => Juha Manninen
2020-04-01 06:06 Juha Manninen Status new => feedback
2020-04-01 06:06 Juha Manninen LazTarget => -
2020-04-01 06:06 Juha Manninen Note Added: 0121809
2020-04-12 23:05 Juha Manninen Status feedback => resolved
2020-04-12 23:05 Juha Manninen Resolution open => unable to reproduce
2020-04-12 23:05 Juha Manninen Widgetset Win32/Win64 => Win32/Win64
2020-04-12 23:05 Juha Manninen Note Added: 0122099