View Issue Details

IDProjectCategoryView StatusLast Update
0036808LazarusIDEpublic2020-06-06 23:44
ReporterCudaText man Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformWin10 x64 
Product Version2.0.6 
Summary0036808: Code Explorer dialog opens on wrong monitor and with small size
DescriptionIDE last release for Win x64, just installed via installer.
IDE window (with component palette) and OI are moved to non-primary monitor, source code editor is also moved there.
Now call Code Explorer dialog:
- it opens on wrong monitor (seems first, not the monitor of main window / OI)
- it has tiny window size, like 150x150 pixels or so
TagsNo tags attached.
Fixed in Revisionr62831
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0034447 closedMichl Lazarus Crash in IDE Docking Mode 

Activities

Juha Manninen

2020-03-19 22:03

developer   ~0121652

> not the monitor of main window / OI
Why should it open in the same monitor as the main window? All IDE windows remember their location and size and use them.

Juha Manninen

2020-03-30 21:28

developer   ~0121781

Last edited: 2020-03-30 21:29

View 2 revisions

> - it has tiny window size, like 150x150 pixels or so
Indeed with a clean configuration at the first time the Code Explorer window is very small. It can be resized and then the new size is remembered.
Why the initial size is so small, I have no idea. The form's design size is much bigger.
I didn't find any clues from the code. Can somebody find the reason?

Martin Friebe

2020-03-31 03:49

manager   ~0121788

Start at main.pp
  procedure TMainIDE.SetupIDEWindowsLayout;

  IDEWindowCreators.Add(NonModalIDEWindowNames[nmiwCodeExplorer],
    nil,@CreateIDEWindow,'72%','120','+170','-200',
    NonModalIDEWindowNames[nmiwMainIDE],alRight);

Juha Manninen

2020-03-31 15:11

developer   ~0121800

Thanks Martin. The tiny size was caused by r59830 from the related issue.
It changed both registeranchordocking.pas of AnchorDocking package and main.pp.
In unit Main the aDockSibling parameter was changed from SourceNoteBook to MainIDE. Does it affect AnchorDocking package? Anyway the bug was questionable because nobody could reproduce it.
I will revert that part. Let's see what happens.

Juha Manninen

2020-03-31 15:16

developer   ~0121801

CudaText man, please test with r62831.

Juha Manninen

2020-04-12 23:10

developer   ~0122100

CudaText man, Ping...

Juha Manninen

2020-06-06 23:44

developer   ~0123285

No feedback. Assuming fixed.

Issue History

Date Modified Username Field Change
2020-03-19 18:21 CudaText man New Issue
2020-03-19 22:03 Juha Manninen Note Added: 0121652
2020-03-30 21:28 Juha Manninen Note Added: 0121781
2020-03-30 21:29 Juha Manninen Note Edited: 0121781 View Revisions
2020-03-31 03:49 Martin Friebe Note Added: 0121788
2020-03-31 14:17 Juha Manninen Assigned To => Juha Manninen
2020-03-31 14:17 Juha Manninen Status new => assigned
2020-03-31 14:55 Juha Manninen Relationship added related to 0034447
2020-03-31 15:11 Juha Manninen Note Added: 0121800
2020-03-31 15:16 Juha Manninen Status assigned => feedback
2020-03-31 15:16 Juha Manninen LazTarget => -
2020-03-31 15:16 Juha Manninen Note Added: 0121801
2020-04-12 23:10 Juha Manninen Note Added: 0122100
2020-06-06 23:44 Juha Manninen Status feedback => resolved
2020-06-06 23:44 Juha Manninen Resolution open => fixed
2020-06-06 23:44 Juha Manninen Fixed in Revision => r62831
2020-06-06 23:44 Juha Manninen Widgetset Win32/Win64 => Win32/Win64
2020-06-06 23:44 Juha Manninen Note Added: 0123285