View Issue Details

IDProjectCategoryView StatusLast Update
0036815LazarusPatchpublic2020-03-21 18:28
ReporterPercy Van Den BylaardtAssigned ToBart Broersma 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionduplicate 
Product Version2.1 (SVN)Product Build62775 
Target VersionFixed in Version 
Summary0036815: gtk2 TmaskEdit
Descriptionsame from 0034678 occurs on 2.1 version
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetGTK 2
Attached Files
  • gtk2wsstdctrls.diff (701 bytes)
    Index: /home/percy/Desenvolvimento/Lazarus/bin/Trunc/lazarus/lcl/interfaces/gtk2/gtk2wsstdctrls.pp
    ===================================================================
    --- /home/percy/Desenvolvimento/Lazarus/bin/Trunc/lazarus/lcl/interfaces/gtk2/gtk2wsstdctrls.pp	(revisão 62775)
    +++ /home/percy/Desenvolvimento/Lazarus/bin/Trunc/lazarus/lcl/interfaces/gtk2/gtk2wsstdctrls.pp	(cópia de trabalho)
    @@ -1419,8 +1419,8 @@
         g_idle_add(@gtk2WSDelayedSetSelLength, WidgetInfo)
       else
         gtk_entry_select_region(Entry,
    -      SelStart,
    -      SelStart + NewLength);
    +      SelStart+ NewLength,
    +      SelStart );
     end;
     
     class procedure TGtk2WSCustomEdit.SetAlignment(const ACustomEdit: TCustomEdit;
    
    gtk2wsstdctrls.diff (701 bytes)

Relationships

duplicate of 0034678 resolvedJuha Manninen TMaskEdit sometimes skips characters 

Activities

Percy Van Den Bylaardt

2020-03-21 01:17

reporter  

gtk2wsstdctrls.diff (701 bytes)
Index: /home/percy/Desenvolvimento/Lazarus/bin/Trunc/lazarus/lcl/interfaces/gtk2/gtk2wsstdctrls.pp
===================================================================
--- /home/percy/Desenvolvimento/Lazarus/bin/Trunc/lazarus/lcl/interfaces/gtk2/gtk2wsstdctrls.pp	(revisão 62775)
+++ /home/percy/Desenvolvimento/Lazarus/bin/Trunc/lazarus/lcl/interfaces/gtk2/gtk2wsstdctrls.pp	(cópia de trabalho)
@@ -1419,8 +1419,8 @@
     g_idle_add(@gtk2WSDelayedSetSelLength, WidgetInfo)
   else
     gtk_entry_select_region(Entry,
-      SelStart,
-      SelStart + NewLength);
+      SelStart+ NewLength,
+      SelStart );
 end;
 
 class procedure TGtk2WSCustomEdit.SetAlignment(const ACustomEdit: TCustomEdit;
gtk2wsstdctrls.diff (701 bytes)

Bart Broersma

2020-03-21 12:33

developer   ~0121671

Since 0034678 isn't marked as resolved, why would you think it was fixed in 2.1?
If the patch in 0034678 is applied (or the issue is otherwise fixed), it will be merged to fixes branch.

Resolving as duplicate.

Percy Van Den Bylaardt

2020-03-21 18:28

reporter   ~0121676

@ Bart,
I had made this patch with version 2.1, not 1.8 as reported in # 0034678
maybe it can also be applied in 1.8.
but now I don't know if the patch works in 1.8 because I don't longer have it installed.

Issue History

Date Modified Username Field Change
2020-03-21 01:17 Percy Van Den Bylaardt New Issue
2020-03-21 01:17 Percy Van Den Bylaardt File Added: gtk2wsstdctrls.diff
2020-03-21 12:33 Bart Broersma Assigned To => Bart Broersma
2020-03-21 12:33 Bart Broersma Status new => resolved
2020-03-21 12:33 Bart Broersma Resolution open => duplicate
2020-03-21 12:33 Bart Broersma LazTarget => -
2020-03-21 12:33 Bart Broersma Widgetset GTK 2 => GTK 2
2020-03-21 12:33 Bart Broersma Note Added: 0121671
2020-03-21 12:33 Bart Broersma Relationship added duplicate of 0034678
2020-03-21 18:28 Percy Van Den Bylaardt Note Added: 0121676