View Issue Details

IDProjectCategoryView StatusLast Update
0036844FPCCompilerpublic2020-03-29 17:26
ReporterBBaz Assigned ToMichael Van Canneyt  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Summary0036844: no "-version" switch
DescriptionIt is common for a compiler to have a "-version" switch, displaying the product name, the vendor, the license, the copyright notice and the version number, so that it can be easily processed by grep to make env variables, but fpc does not have one.

-h displays the version but this also comes with a full list of the cmd line args.
Steps To Reproduce$ fpc -version
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Relationships

related to 0036846 closedJonas Maebe Add "--version" switch 

Activities

Michael Van Canneyt

2020-03-29 15:33

administrator   ~0121751

Last edited: 2020-03-29 15:34

View 2 revisions

When you read the output of -h carefully, you will notice that
fpc -iV
or
fpc -iW
does exactly what you need.

Since version 2.2.0.

Issue History

Date Modified Username Field Change
2020-03-29 15:12 BBaz New Issue
2020-03-29 15:33 Michael Van Canneyt Assigned To => Michael Van Canneyt
2020-03-29 15:33 Michael Van Canneyt Status new => resolved
2020-03-29 15:33 Michael Van Canneyt Resolution open => no change required
2020-03-29 15:33 Michael Van Canneyt FPCTarget => -
2020-03-29 15:33 Michael Van Canneyt Note Added: 0121751
2020-03-29 15:34 Michael Van Canneyt Note Edited: 0121751 View Revisions
2020-03-29 17:26 Tomas Hajny Relationship added related to 0036846