View Issue Details

IDProjectCategoryView StatusLast Update
0036851FPCFCLpublic2020-04-20 17:56
ReporterEric Heijnen Assigned ToMichael Van Canneyt  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Platformx86_64OSMacOS 
Product Version3.3.1 
Fixed in Version3.3.1 
Summary0036851: TFPCustomHTTPClient: FormPost doesn't allow sizechange after using once
DescriptionWhen using FormPost more than once on the same FPCustomHTTPclient it's impossible to give a different size in formdata. If you go further the data gets cut off, and if you use less the program crashes
Steps To ReproduceI've attached an example project that posts some data and checks if the data posted is correct
TagsNo tags attached.
Fixed in Revision44775
FPCOldBugId
FPCTarget3.2.0
Attached Files

Activities

Eric Heijnen

2020-03-30 13:35

reporter  

Archive.zip (1,373 bytes)

Michael Van Canneyt

2020-04-18 12:37

administrator   ~0122221

The problem was not the buffer, but the automatically added content-length header.
When added, it needs to be removed again after the headers were sent,
otherwise the next requests will reuse the value of the first requests.

Issue History

Date Modified Username Field Change
2020-03-30 13:35 Eric Heijnen New Issue
2020-03-30 13:35 Eric Heijnen File Added: Archive.zip
2020-04-01 09:45 Michael Van Canneyt Assigned To => Michael Van Canneyt
2020-04-01 09:45 Michael Van Canneyt Status new => assigned
2020-04-18 12:37 Michael Van Canneyt Status assigned => resolved
2020-04-18 12:37 Michael Van Canneyt Resolution open => fixed
2020-04-18 12:37 Michael Van Canneyt Fixed in Version => 3.3.1
2020-04-18 12:37 Michael Van Canneyt Fixed in Revision => 44775
2020-04-18 12:37 Michael Van Canneyt FPCTarget => 3.2.0
2020-04-18 12:37 Michael Van Canneyt Note Added: 0122221