View Issue Details

IDProjectCategoryView StatusLast Update
0036868FPCRTLpublic2020-04-04 22:41
ReporterBi0T1N Assigned ToFlorian  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.3.1 
Fixed in Version3.3.1 
Summary0036868: Missing semicolon for epoll_create function if generic_linux_syscalls is defined
DescriptionThe semicolon for the epoll_create function is missing if generic_linux_syscalls is defined

function epoll_create(size: cint): cint;
begin
{$if defined(generic_linux_syscalls)}
  epoll_create := do_syscall(syscall_nr_epoll_create1,0)  <--
{$else}
  epoll_create := do_syscall(syscall_nr_epoll_create,tsysparam(size));
{$endif}
end;
TagsNo tags attached.
Fixed in Revision44578
FPCOldBugId
FPCTarget-
Attached Files

Activities

Marco van de Voort

2020-04-04 16:25

manager   ~0121901

Last edited: 2020-04-04 16:25

View 2 revisions

Shouldn't be a problem since semicolons before end can be omitted?

What is the error you get?

Bi0T1N

2020-04-04 18:44

reporter   ~0121906

Didn't compiled so no error. Just noticed that it is missing there while the rest of the code has it (coding style).

Issue History

Date Modified Username Field Change
2020-04-04 01:18 Bi0T1N New Issue
2020-04-04 16:25 Marco van de Voort Note Added: 0121901
2020-04-04 16:25 Marco van de Voort Note Edited: 0121901 View Revisions
2020-04-04 18:44 Bi0T1N Note Added: 0121906
2020-04-04 22:04 Florian Assigned To => Florian
2020-04-04 22:04 Florian Status new => resolved
2020-04-04 22:04 Florian Resolution open => fixed
2020-04-04 22:04 Florian Fixed in Version => 3.3.1
2020-04-04 22:04 Florian Fixed in Revision => 44578
2020-04-04 22:04 Florian FPCTarget => -
2020-04-04 22:41 Bi0T1N Status resolved => closed