View Issue Details

IDProjectCategoryView StatusLast Update
0036876LazarusIDEpublic2020-04-08 12:43
ReporterAndi Friess Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformDell XPSOSWin10 / 64 Pro 
Product Version2.0.7 (SVN) 
Summary0036876: Packageeditor duplicates LCL entries and Crash at compile
DescriptionIn Lazarus IDE (32 Bit) trunk or fixes20
*) Create a new Package
*) Add a new Component with Ancestor Type TButton Name it TButton1
*) Accept it with the Create New Component button
-> LCL will added to the Required Packages
*) Add a new Component with Ancestor Type TButton Name it TButton2
*) Accept it with the Create New Component button
-> LCL will added too ! You have LCL now twice
-> Press compile -> boom
Additional InformationIt is in actual fixes too, it looks like an older feature
TagsNo tags attached.
Fixed in Revisionr62907, r62910
LazTarget-
Widgetset
Attached Files

Activities

Andi Friess

2020-04-05 14:56

reporter  

Anmerkung 2020-04-05 145305.jpg (39,499 bytes)   
Anmerkung 2020-04-05 145305.jpg (39,499 bytes)   

Juha Manninen

2020-04-07 23:29

developer   ~0122012

Fixed, please test.

Andi Friess

2020-04-08 12:43

reporter   ~0122029

It is ok, THX

Issue History

Date Modified Username Field Change
2020-04-05 14:56 Andi Friess New Issue
2020-04-05 14:56 Andi Friess File Added: Anmerkung 2020-04-05 145305.jpg
2020-04-07 23:04 Juha Manninen Assigned To => Juha Manninen
2020-04-07 23:04 Juha Manninen Status new => assigned
2020-04-07 23:29 Juha Manninen Status assigned => resolved
2020-04-07 23:29 Juha Manninen Resolution open => fixed
2020-04-07 23:29 Juha Manninen Fixed in Revision => r62907
2020-04-07 23:29 Juha Manninen LazTarget => -
2020-04-07 23:29 Juha Manninen Note Added: 0122012
2020-04-07 23:43 Juha Manninen Description Updated View Revisions
2020-04-07 23:43 Juha Manninen Fixed in Revision r62907 => r62907, r62910
2020-04-08 12:43 Andi Friess Status resolved => closed
2020-04-08 12:43 Andi Friess Note Added: 0122029