View Issue Details

IDProjectCategoryView StatusLast Update
0036881FPCPackagespublic2020-04-10 07:41
ReporterAnton Kavalenka Assigned ToMichael Van Canneyt  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version3.3.1 
Summary0036881: fcl-pdf: For some monospace TTF cyrillic text not rendered properly
DescriptionRun the fcl-pdf/examples/metautf16
with examples/Fonts/FreeSans.ttf symlinked to
/usr/share/fonts/truetype/dejavu/DejaVuSansMono.ttf
or Microsoft "Courier New"
/usr/share/fonts/truetype/msttcorefonts/Courier_New.ttf
Steps To Reproducecompile and run fcl-pdf/examples/metautf16 in mode Delphi
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Relationships

duplicate of 0035251 acknowledgedMichael Van Canneyt fcl-pdf: Writing text in "Courier New" TTF font generates wrong PDF document 

Activities

Anton Kavalenka

2020-04-06 17:04

reporter  

test.pdf (11,048 bytes)

Anton Kavalenka

2020-04-06 18:48

reporter   ~0121981

Looks like Courier_New uses the same glyph for Latin and Cyrillic "O" and "o" and for latin "p" (:pe) and cyrillic "р" (:er)

Anton Kavalenka

2020-04-09 16:14

reporter   ~0122044

Please close as this report is essentially a duplicate of 0035251

Issue History

Date Modified Username Field Change
2020-04-06 17:04 Anton Kavalenka New Issue
2020-04-06 17:04 Anton Kavalenka File Added: test.pdf
2020-04-06 18:48 Anton Kavalenka Note Added: 0121981
2020-04-07 07:17 LacaK Relationship added related to 0035251
2020-04-09 16:14 Anton Kavalenka Note Added: 0122044
2020-04-09 17:32 Michael Van Canneyt Assigned To => Michael Van Canneyt
2020-04-09 17:32 Michael Van Canneyt Status new => assigned
2020-04-09 23:39 Michael Van Canneyt Status assigned => resolved
2020-04-09 23:39 Michael Van Canneyt Resolution open => duplicate
2020-04-09 23:39 Michael Van Canneyt FPCTarget => -
2020-04-09 23:39 Michael Van Canneyt Relationship replaced duplicate of 0035251
2020-04-10 07:41 Anton Kavalenka Status resolved => closed