View Issue Details

IDProjectCategoryView StatusLast Update
0036902FPCCompilerpublic2020-04-16 18:39
ReporterKarl-Michael Schindler Assigned ToMarco van de Voort  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformdarwinOSMac OS X 
Product Version3.3.1 
Summary0036902: iso mode: Assigning a character to a file variable gives runtime error 104
DescriptionThe following program results in run time error 104, which stands for "File not open for input."

For standard output:

program fileTest1 (output);
begin
  output^ := 'a';
end.

For specified text file:

program fileTest2 (outData);
var
  outData: text;
begin
  rewrite(outData);
  outData^ := 'a';
end.

The trunk version of fpc works. I do not really know, what needs to be merged.
Steps To Reproducefpc -Miso fileTest1.pas
./fileTest1

fpc -Miso fileTest2.pas
./fileTest2
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Activities

Karl-Michael Schindler

2020-04-12 18:18

reporter  

fileTest1.pas (58 bytes)   
program fileTest3 (output);

begin
  output^ := 'a';
end.
fileTest1.pas (58 bytes)   
fileTest2.pas (102 bytes)   
program fileTest2 (outData);

var
  outData: text;

begin
  rewrite(outData);
  outData^ := 'a';
end.
fileTest2.pas (102 bytes)   

Karl-Michael Schindler

2020-04-13 15:29

reporter   ~0122126

I found the commit to trunk, which resolves this issue. It is #41429. Actually, this has been merged to the 3.2-fixes branch with commit 44301, but just did not make into RC1.

So, I think that basically, this issue is resolved.

Marco van de Voort

2020-04-16 13:16

manager   ~0122172

I happened to have a recent snapshot compiled and installed, so I quickly tested, and fixes indeed gives no RTE

Karl-Michael Schindler

2020-04-16 18:39

reporter   ~0122177

Thanks for caring.

Issue History

Date Modified Username Field Change
2020-04-12 18:18 Karl-Michael Schindler New Issue
2020-04-12 18:18 Karl-Michael Schindler File Added: fileTest1.pas
2020-04-12 18:18 Karl-Michael Schindler File Added: fileTest2.pas
2020-04-13 15:29 Karl-Michael Schindler Note Added: 0122126
2020-04-16 13:16 Marco van de Voort Assigned To => Marco van de Voort
2020-04-16 13:16 Marco van de Voort Status new => resolved
2020-04-16 13:16 Marco van de Voort Resolution open => unable to reproduce
2020-04-16 13:16 Marco van de Voort FPCTarget => -
2020-04-16 13:16 Marco van de Voort Note Added: 0122172
2020-04-16 18:39 Karl-Michael Schindler Status resolved => closed
2020-04-16 18:39 Karl-Michael Schindler Note Added: 0122177