View Issue Details

IDProjectCategoryView StatusLast Update
0036951FPCCompilerpublic2020-07-04 19:17
ReporterKarl-Michael Schindler Assigned ToSven Barth  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionreopened 
PlatformdarwinOSMac OS X 
Product Version3.3.1 
Fixed in Version3.3.1 
Summary0036951: Revision 44933 breaks building aarch64-linux on macOS
DescriptionAfter revision 44933, building the crosscompiler for aarch64-linux breaks with:

...
/BlaBla/FreePascal/compiler/ppcrossa64 -Ur -Tlinux -Paarch64 -XPaarch64-linux- -Xr -Ur -Xs -O2 -n -Fi../inc -Fi../aarch64 -Fi../unix -Fiaarch64 -FE. -FU/BlaBla/FreePascal/rtl/units/aarch64-linux -ap -v0 -Fl/Library/Developer/CommandLineTools/SDKs/MacOSX.sdk/usr/lib -O- -daarch64 -dRELEASE -Us -Sg system.pp
syscall.inc(18,6) Fatal: Internal error 2014122002

It has not been resolved up to revision 44995.
Steps To Reproducesvn up -r 44933
make -j 4 clean all FPMAKEOPT="-T 4" OPT="-ap -v0 -Fl/Library/Developer/CommandLineTools/SDKs/MacOSX.sdk/usr/lib" OS_TARGET=linux CPU_TARGET=aarch64
Additional InformationI do not think it matters, but for the sake of completeness: The host system is macOS 10.15 and starting compiler is fpc 3.0.4 64-bit installed using fink.

The issue has not been resolved up to revision 44995.
TagsNo tags attached.
Fixed in Revision44998,44999
FPCOldBugId
FPCTarget-
Attached Files

Relationships

has duplicate 0036952 resolvedSven Barth aarch64-android - Fatal: Internal error 2014122002 

Activities

Sven Barth

2020-04-22 20:29

manager   ~0122343

@Florian: did you just resolve a bug report as a duplicate of a bug report that I had already resolved as a duplicate of this one? O.o I wanted to keep this one open, cause it has the revision...

Florian

2020-04-22 21:01

administrator   ~0122344

Yes, I thought the duplicate was solved, so I tried to get rid of this one well :) Sorry.

Sven Barth

2020-04-22 22:22

manager   ~0122346

Please test and close if okay.

Karl-Michael Schindler

2020-04-22 23:11

reporter   ~0122347

i can confirm the fix, but for a final close, i seem to have to reopen it again.

Sven Barth

2020-04-23 09:56

manager   ~0122350

Stupid Mantis... Okay, then you may try to close it now. :)

Karl-Michael Schindler

2020-07-04 19:17

reporter   ~0123753

thanks you all.

Issue History

Date Modified Username Field Change
2020-04-22 13:02 Karl-Michael Schindler New Issue
2020-04-22 16:16 Sven Barth Relationship added has duplicate 0036952
2020-04-22 20:22 Florian Assigned To => Florian
2020-04-22 20:22 Florian Status new => resolved
2020-04-22 20:22 Florian Resolution open => duplicate
2020-04-22 20:22 Florian FPCTarget => -
2020-04-22 20:29 Sven Barth Assigned To Florian =>
2020-04-22 20:29 Sven Barth Status resolved => feedback
2020-04-22 20:29 Sven Barth Resolution duplicate => reopened
2020-04-22 20:29 Sven Barth Note Added: 0122343
2020-04-22 21:01 Florian Note Added: 0122344
2020-04-22 22:21 Sven Barth Assigned To => Sven Barth
2020-04-22 22:21 Sven Barth Status feedback => assigned
2020-04-22 22:22 Sven Barth Status assigned => resolved
2020-04-22 22:22 Sven Barth Fixed in Version => 3.3.1
2020-04-22 22:22 Sven Barth Fixed in Revision => 44998,44999
2020-04-22 22:22 Sven Barth Note Added: 0122346
2020-04-22 22:22 Sven Barth Resolution reopened => fixed
2020-04-22 23:11 Karl-Michael Schindler Status resolved => feedback
2020-04-22 23:11 Karl-Michael Schindler Resolution fixed => reopened
2020-04-22 23:11 Karl-Michael Schindler Note Added: 0122347
2020-04-23 09:56 Sven Barth Status feedback => resolved
2020-04-23 09:56 Sven Barth Note Added: 0122350
2020-07-04 19:17 Karl-Michael Schindler Status resolved => closed
2020-07-04 19:17 Karl-Michael Schindler Note Added: 0123753