View Issue Details

IDProjectCategoryView StatusLast Update
0036962FPCDocumentationpublic2020-04-24 16:07
ReporterThaddy de Koning Assigned ToMichael Van Canneyt  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformAllOSAll 
Product Version3.3.1 
Summary0036962: The documentation for {$packrecords C} is incomple
DescriptionSee https://forum.lazarus.freepascal.org/index.php/topic,49492.msg358895.html#msg358895

The documentation only states that {packrecords C} is for GNU cc, but as Sven pointed out on the forum it is actually for a platforms default compiler:
" it's for the target's default C alignment. For example on Windows if MSVC would use default alignment 4 and GNU C would use default alignment 1 then FPC would follow MSVC and not GNU C."
Steps To ReproduceExamine https://www.freepascal.org/docs-html/current/prog/progsu60.html
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Activities

Michael Van Canneyt

2020-04-24 16:07

administrator   ~0122380

This is already fixed in trunk since quite some time.

Issue History

Date Modified Username Field Change
2020-04-24 15:28 Thaddy de Koning New Issue
2020-04-24 15:28 Thaddy de Koning Status new => assigned
2020-04-24 15:28 Thaddy de Koning Assigned To => Michael Van Canneyt
2020-04-24 16:07 Michael Van Canneyt Status assigned => resolved
2020-04-24 16:07 Michael Van Canneyt Resolution open => fixed
2020-04-24 16:07 Michael Van Canneyt FPCTarget => -
2020-04-24 16:07 Michael Van Canneyt Note Added: 0122380