View Issue Details

IDProjectCategoryView StatusLast Update
0036966MantisWebsitepublic2020-04-30 12:38
ReporterFTurtle Assigned ToMichael Van Canneyt  
PrioritynormalSeverityminorReproducibilityalways
Status newResolutionreopened 
Summary0036966: Mantis: The "Product Build" field is not displayed on issue viewing page
DescriptionThe "Product Build" field is not displayed on issue viewing page.
In particular, I remember that I mentioned revision number in 0036965 when creating report but this information is absent on report viewing page.
Also I can't see this field in my old reports although I enter it almost always.
TagsNo tags attached.
Attached Files

Activities

Michael Van Canneyt

2020-04-24 23:11

administrator   ~0122393

Please ask on the lazarus mailing list or forum if someone removed this field.
I see no evidence of this field in the manage section of the bugtracker.

FTurtle

2020-04-25 00:55

reporter   ~0122395

https://forum.lazarus.freepascal.org/index.php/topic,49509.0.html

Martin Friebe

2020-04-25 14:07

manager   ~0122411

The field is indeed visible when reporting a bug.

At some stage in the past, there was a simple and an advanced view, when looking at a bug. I no longer find the option for the advanced view.

Maybe this part of the doc is related:
http://www.mantisbt.org/docs/master/en-US/Admin_Guide/html-desktop/

5.23. Filters
$g_view_filters = SIMPLE_DEFAULT;
    Controls the display of the filter pages. Possible values are:
        SIMPLE_ONLY - only allow use of simple view
        ADVANCED_ONLY - only allow use of advanced view (allows multiple value selections)
        SIMPLE_DEFAULT - defaults to simple view, but shows a link for advanced
        ADVANCED_DEFAULT - defaults to advanced view, but shows a link for simple

FTurtle

2020-04-26 15:39

reporter   ~0122450

Last edited: 2020-04-26 15:43

View 2 revisions

http://www.mantisbt.org/docs/master/en-US/Admin_Guide/html-desktop/#admin.config.fields

5.35. Field Visibility

$g_enable_eta
    Enable or disable usage of 'ETA' field. Default value is OFF.
$g_enable_projection
    Enable or disable usage of 'Projection' field. Default value is OFF.
$g_enable_product_build
    Enable or disable usage of 'Product Build' field. Default is OFF.

I think we just should set $g_enable_product_build to ON
Looks like default value was changed when upgraded FPC/Lazarus bugtracker.

Michael Van Canneyt

2020-04-26 16:38

administrator   ~0122452

I set the field to on. I can see it when editing a bugreport, please check if it fixes the issue for you.

FTurtle

2020-04-29 21:52

reporter   ~0122530

Last edited: 2020-04-29 22:09

View 2 revisions

Unfortunately trouble is not solved.
Field "Product Build" was (and is) visible at page of creating new report (excepting some projects like 'Mantis') but not visible at page of viewing details of existing report. Some time earlier (at least before upgrading Mantis) this field was visible and located the right of the "Product Version" field.

The next assumption is to try include needed field ('build' or may be 'product_build') to list $g_bug_view_page_fields in file config_defaults_inc.php

Also there is a comment in config_defaults_inc.php:
* This setting can be set on a per-project basis by using the
 * Manage => Manage Configuration administrator page.


Edited:

I'm little wrong about file name.
Another comment from config_defaults_inc.php:

/**
 * Default Configuration Variables
 *
 * This file should not be changed. If you want to override any of the values
 * defined here, define them in a file called config/config_inc.php, which will
 * be loaded after this file.
 *
 * In general a value of OFF means the feature is disabled and ON means the
 * feature is enabled. Any other cases will have an explanation.
 *
 * For more details see https://www.mantisbt.org/docs/master/
 *
 * @package MantisBT
 * @copyright Copyright 2000 - 2002 Kenzaburo Ito - kenito@300baud.org
 * @copyright Copyright 2002 MantisBT Team - mantisbt-dev@lists.sourceforge.net
 * @link http://www.mantisbt.org
 */

Michael Van Canneyt

2020-04-29 23:38

administrator   ~0122533

I added the build field to all possible categories for all projects

FTurtle

2020-04-30 12:16

reporter   ~0122553

Field "Product Build" is still not visible at page "View Issue Details".

Michael Van Canneyt

2020-04-30 12:21

administrator   ~0122554

In that case I give up. There are various other regressions in this update, I suppose this is one of them :(

Issue History

Date Modified Username Field Change
2020-04-24 21:00 FTurtle New Issue
2020-04-24 23:11 Michael Van Canneyt Assigned To => Michael Van Canneyt
2020-04-24 23:11 Michael Van Canneyt Status new => feedback
2020-04-24 23:11 Michael Van Canneyt Note Added: 0122393
2020-04-25 00:55 FTurtle Note Added: 0122395
2020-04-25 00:55 FTurtle Status feedback => assigned
2020-04-25 14:07 Martin Friebe Note Added: 0122411
2020-04-26 15:39 FTurtle Note Added: 0122450
2020-04-26 15:43 FTurtle Note Edited: 0122450 View Revisions
2020-04-26 16:38 Michael Van Canneyt Status assigned => resolved
2020-04-26 16:38 Michael Van Canneyt Resolution open => fixed
2020-04-26 16:38 Michael Van Canneyt Note Added: 0122452
2020-04-29 21:52 FTurtle Status resolved => feedback
2020-04-29 21:52 FTurtle Resolution fixed => reopened
2020-04-29 21:52 FTurtle Note Added: 0122530
2020-04-29 22:09 FTurtle Note Edited: 0122530 View Revisions
2020-04-29 23:38 Michael Van Canneyt Status feedback => resolved
2020-04-29 23:38 Michael Van Canneyt Note Added: 0122533
2020-04-29 23:38 Michael Van Canneyt Status resolved => closed
2020-04-30 12:16 FTurtle Status closed => feedback
2020-04-30 12:16 FTurtle Note Added: 0122553
2020-04-30 12:21 Michael Van Canneyt Note Added: 0122554
2020-04-30 12:38 FTurtle Status feedback => new