View Issue Details

IDProjectCategoryView StatusLast Update
0036979LazarusLCLpublic2020-04-29 09:09
ReporterJohannes W. Dietrich Assigned ToMaxim Ganetsky  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
PlatformReactOSOSReactOS 
Product Version2.0.6 
Summary0036979: TImages flipped in ReactOS
DescriptionIn multiple programs built with Lazarus, some Images are flipped in the ReactOS operating system. I am not sure if the bug is in ReactOS or in the LCL but it occurs only in this combination (ReactOS + application created with Lazarus)
Steps To ReproduceOccurs at every start.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

Johannes W. Dietrich

2020-04-27 22:14

reporter  

Marco van de Voort

2020-04-27 22:17

manager   ~0122476

Image flipping images with ReactOS already have been reported there:

https://jira.reactos.org/browse/CORE-6320 (though afaik for icons).

I assume they don't properly support either topdown or bottomup images?

Johannes W. Dietrich

2020-04-27 22:30

reporter   ~0122477

It has been reported to have been fixed in 2015. However, the problem is still persisting, and it isn't restricted to icons.

jamie philbrook

2020-04-27 22:55

reporter   ~0122478

The height of the image in the Bitmap header must be a -value for top down and +value for bottom up.

I haven't checked this myself is it possible most software these days are ignoring this flag and assuming all should be bottom up?

 If other BMPs from other sources show correctly then maybe the ReactOS is obeying these rules but like I said, I haven't checked what Laz does or where ever the BMP is created.

Sven Barth

2020-04-28 09:46

manager   ~0122483

As mentioned by the ReactOS devs, this bug is tracked in https://jira.reactos.org/browse/CORE-14671. This is not the LCL's fault, so this here should be closed.

Maxim Ganetsky

2020-04-28 14:10

developer   ~0122493

OK, resolving.

Johannes W. Dietrich

2020-04-29 09:09

reporter   ~0122515

Thanks for the info. The issue is now reported in the ReactOS bug tracker at https://jira.reactos.org/browse/CORE-16984 .

Issue History

Date Modified Username Field Change
2020-04-27 22:14 Johannes W. Dietrich New Issue
2020-04-27 22:14 Johannes W. Dietrich File Added: VirtualBox_Reactos 0.4.13_27_04_2020_22_00_58.png
2020-04-27 22:14 Johannes W. Dietrich File Added: VirtualBox_Reactos 0.4.13_27_04_2020_22_04_41.png
2020-04-27 22:14 Johannes W. Dietrich File Added: VirtualBox_Reactos 0.4.13_27_04_2020_22_05_31.png
2020-04-27 22:17 Marco van de Voort Note Added: 0122476
2020-04-27 22:30 Johannes W. Dietrich Note Added: 0122477
2020-04-27 22:55 jamie philbrook Note Added: 0122478
2020-04-28 09:46 Sven Barth Note Added: 0122483
2020-04-28 14:10 Maxim Ganetsky Assigned To => Maxim Ganetsky
2020-04-28 14:10 Maxim Ganetsky Status new => resolved
2020-04-28 14:10 Maxim Ganetsky Resolution open => no change required
2020-04-28 14:10 Maxim Ganetsky LazTarget => -
2020-04-28 14:10 Maxim Ganetsky Widgetset Win32/Win64 => Win32/Win64
2020-04-28 14:10 Maxim Ganetsky Note Added: 0122493
2020-04-29 09:09 Johannes W. Dietrich Note Added: 0122515